Product simple attributes missing

Started by MTechMgr, May 09, 2016, 20:51:22 PM

Previous topic - Next topic

MTechMgr

Product simple attributes (like color) missing from product details page after moving to new server. I've saved product with simple attributes but nothing shows up.
I'm using flypage.tpl.php of my template in VM 1.1.9

I guess i need to make a query in db and show it with an echo?
Tried adding this line  <?php echo $ps_product_attribute->list_advanced_attribute($product_id); ?>  in the file but nothing shows up.

jenkinhill

Kelvyn
Lowestoft, Suffolk, UK

Retired from forum life November 2023

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

MTechMgr

I configured the server to native 5.4 from cPanel. Only this version shows the template perfect.

MTechMgr


jenkinhill

You can post it, but I no longer use or support VM1.1 - much too old!  As this issue appeared when you moved host then there has to be something different, and PHP version is to me the most logical. But there are some VM1.1 users who visit, so maybe one of them has seen this problem.
Kelvyn
Lowestoft, Suffolk, UK

Retired from forum life November 2023

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

MTechMgr

Then there is no need for the link. I thought the same about the host but I needed an extra opinion. Do you think I should create child products?

GJC Web Design

I have a few clients still on vm1.1 and generally the sites are very stable

it does seem odd that just a display attribute would go missing.. is there an empty div etc?
with full error reporting do u see anything?
GJC Web Design
VirtueMart and Joomla Developers - php developers [url="https://www.gjcwebdesign.com"]https://www.gjcwebdesign.com[/url]
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
[url="https://extensions.joomla.org/profile/profile/details/67210"]https://extensions.joomla.org/profile/profile/details/67210[/url]
Contact for any VirtueMart or Joomla development & customisation

MTechMgr

An empty div, no. I have bouble checked the flypage.tpl.php file. Using firebug I don't find anything strange. In the previous host everything looked perfect.

GJC Web Design

GJC Web Design
VirtueMart and Joomla Developers - php developers [url="https://www.gjcwebdesign.com"]https://www.gjcwebdesign.com[/url]
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
[url="https://extensions.joomla.org/profile/profile/details/67210"]https://extensions.joomla.org/profile/profile/details/67210[/url]
Contact for any VirtueMart or Joomla development & customisation

MTechMgr

The funny thing is that the specific file for product details: flypage.tpl.php is the same from the previous host. Never changed with tweaks or anything else.

GJC Web Design

yes.. but that just displays data sent to it

you need to look back in admin -> classes -> ps_product.php is it?

been years since I dug in VM1.1

but surely if it fails because of the php version is different an error must be logged somewhere

have you tried with debug etc etc etc
GJC Web Design
VirtueMart and Joomla Developers - php developers [url="https://www.gjcwebdesign.com"]https://www.gjcwebdesign.com[/url]
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
[url="https://extensions.joomla.org/profile/profile/details/67210"]https://extensions.joomla.org/profile/profile/details/67210[/url]
Contact for any VirtueMart or Joomla development & customisation

MTechMgr

This is a bit hard for me to do. I'm not a programmer. Just an admin of my site for some years reading forums for solutions to my problems.
Anyway, thx for your time and advices. ;)

GJC Web Design

GJC Web Design
VirtueMart and Joomla Developers - php developers [url="https://www.gjcwebdesign.com"]https://www.gjcwebdesign.com[/url]
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
[url="https://extensions.joomla.org/profile/profile/details/67210"]https://extensions.joomla.org/profile/profile/details/67210[/url]
Contact for any VirtueMart or Joomla development & customisation

Jörgen

Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

Quick Reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name:
Email:
Verification:
Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
7+4+3:
Shortcuts: ALT+S post or ALT+P preview