Author Topic: Images not showing  (Read 1563 times)

SPGroupinc

  • Beginner
  • *
  • Posts: 7
  • A beginner
Images not showing
« on: September 28, 2015, 18:23:18 pm »
I am using Virtuemart 3.0.9 with Joomla 3.3.6. I have loaded the sample data on this site but the images are not showing. I've tried everything I can find online and still can't get any images to show. Please note that the site you are viewing only has sample data on it because I don't want to go through adding all our products until I know everything is working.  http://www.spg-inc.us/coopersgem/index.php/shop-coopers Does anyone know how I can fix this?

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10695
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.8.8
Re: Images not showing
« Reply #1 on: September 28, 2015, 23:20:18 pm »
Its your template

you have lazy loading but the JS is broken and not unhiding them

Code: [Select]
<div class="vm-product-media-container">

<a href="/coopersgem/index.php/shop-coopers/headpiece/cowboy-hat-detail" title="Cowboy Hat">
<span style="width: px;" class="lazy lazy_container lazyloaded"><span style="padding-top: 0%;" class="lazy lazy_preloader"></span><img class="lazy browseProductImage" alt="virtuemart sample" src="/coopersgem/images/stories/virtuemart/product/resized/hat3_0x90.png" style="display: block;"></span> </a>

</div>
GJC Web Design
VirtueMart and Joomla Developers - php developers https://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
https://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

SPGroupinc

  • Beginner
  • *
  • Posts: 7
  • A beginner
Re: Images not showing
« Reply #2 on: September 29, 2015, 15:45:07 pm »
Thank you for the quick response! Forgive me if this is a simple question but how would I go about fixing that?

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10695
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.8.8
Re: Images not showing
« Reply #3 on: September 29, 2015, 20:23:03 pm »
I have no idea.. it is a mistake/bug/mis-configuration in your template

either get the templater to fix it or employ someone to fix it.. it is your template that is at fault
GJC Web Design
VirtueMart and Joomla Developers - php developers https://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
https://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation