News:

You may pay someone to create your store, or you visit our seminar and become a professional yourself with the silver certification

Main Menu

Migration and Upgrade help please.

Started by Mister Paul, May 31, 2015, 10:56:49 AM

Previous topic - Next topic

Mister Paul

Hi,
my hoster will no more support older versions of PHP so I'd need to clean a lot :

- PHP 5.2.17 to PHP 5.6
- Joomla 1.5 to 3.4
- Virtuemart de 1.1.4 to 3.0.6
- plugins, modules,...
- rewrite template
:o

What would be your advises for the migration process?

Thanks
Paul

GJC Web Design

don't get your question?

A mans gotta do what a mans gotta do...   ;)

plenty of advise already on here
GJC Web Design
VirtueMart and Joomla Developers - php developers [url="https://www.gjcwebdesign.com"]https://www.gjcwebdesign.com[/url]
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
[url="https://extensions.joomla.org/profile/profile/details/67210"]https://extensions.joomla.org/profile/profile/details/67210[/url]
Contact for any VirtueMart or Joomla development & customisation

Mister Paul

 ;)

I was wondering is there was an order to respect. A chronological step by step process. Because all that stuff to update seemed heavy to manage for me.

I just heard about Migrator that could do the job in an easy way
http://extensions.joomla.org/extensions/extension/extension-specific/virtuemart-extensions/migrator-for-virtuemart

What do you think about it?
::)

jenkinhill

Kelvyn
Lowestoft, Suffolk, UK

Retired from forum life November 2023

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Mister Paul

#4
You signature makes me wondering if there's a more stable couple Joomla/Virtuemart to use...

I'm going to update a ┬▒five years old site, with no problems and I hope to get a new one stable, secure for years with almost no bug during site installation.

Last versions work OK together in this trio?
- PHP 5.6
- Joomla 3.4
- Virtuemart 3.0.6

GJC Web Design

#5
the latest is 3.0.9 ->  http://dev.virtuemart.net/attachments/download/949/com_virtuemart.3.0.9_extract_first.zip

3.0.10 is still under going pre-release testing

Re the upgrade - you have to be methodical and follow the advice - I as a rough estimate always allow 3-4 hours
The most difficult part is the Joomla upgrades with all the different extension requirements

But if u do it on a clone .. if it messes up -- you can always re try
GJC Web Design
VirtueMart and Joomla Developers - php developers [url="https://www.gjcwebdesign.com"]https://www.gjcwebdesign.com[/url]
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
[url="https://extensions.joomla.org/profile/profile/details/67210"]https://extensions.joomla.org/profile/profile/details/67210[/url]
Contact for any VirtueMart or Joomla development & customisation