News:

Looking for documentation? Take a look on our wiki

Main Menu

Language Switcher bug?

Started by 2cool, May 22, 2015, 14:41:06 PM

Previous topic - Next topic

2cool

Hi,
got my store set but noticed something strange;

If in Language Switcher the active language is set to 'YES' both languages are visible.
But virtuemart category page doesn't switch 'at once' but after 2 clicks???

If in Language Switcher active language is set to 'NO' it works fine?

Could anyone explain what happens an how to fix!

Thanks and regards,

Pascal

ps. joomla pages switch ok with both settings.

setting: Joomla! 3.4.1 / VirtueMart 3.0.8 / Dutch + German languages active

grupposis

Same problem for me! Any solution?

grupposis

I solved with this:

I replaced the joomla 3.4.1 /plugins/system/languagefilter with the joomla 3.3.6 version and this particular issue was resolved.

2cool

Wow, thanks works great!
Any idea what's causing this and if this will be fixed at next update?


jjk

Quote from: 2cool on May 26, 2015, 13:22:20 PM
Any idea what's causing this and if this will be fixed at next update?
The problem with the new Joomla router is that if there is no itemId given, it uses the homepage Itemid as fallback.
The popup uses the last used itemId, which works well in j2.5, but not in j3.4.1

There will be a fix for it in VM 3.0.10. With that the popup keeps the currently used language when 'Language Javascript Fix' is enabled in VM Configuration > Checkout tab (just tested successfully).

But don't forget to revert your 'hack' (using the Joomla 3.3.6 version of languagefilter.php)!!!
Non-English Shops: Are your language files up to date?
[url="http://virtuemart.net/community/translations"]http://virtuemart.net/community/translations[/url]