News:

Support the VirtueMart project and become a member

Main Menu

Problem with Menu and SEF404

Started by selor, September 03, 2014, 20:22:09 PM

Previous topic - Next topic

selor

HI,

i am not sure where post this problem .

I am under last version of virtuemart : VirtueMart 2.6.6
and this version of Sef404 :4.4.4.1791

But it seems its a problem generated by the menu item creator for virtuemart but i am not sure so i explain the facts :

When you create a menu item and choose "Show a category of virtuemart"
it makes a link like this :

I have compared the link who generate problems :

on these type of NON sef url its working normally :
index.php?option=com_virtuemart&view=category&virtuemart_category_id=7   

For this one Sef404 recreate a rewriting using this structure :
http://domain.com/menuitemjoomlaAlias/Aliasofthecategoryfromvirtuemart
Like on my website :
https://www.kubevent.fr/location/videoprojecteurs

On these ones it not works :
index.php?option=com_virtuemart&view=category&virtuemart_category_id=25&categorylayout=0
on this one with sef404 ACTIVE and router.php of joomla Off it point on this like on my website !
https://www.kubevent.fr/location?categorylayout=0

How solve this annoying bug ?

Thanks ..
Production: Joomla 2.5.8 | VM 2.0.15d | PHP Version 5.3.19 Apache 2.0 Handler

Safe Mode : Disabled
Disabled Functions:set_time_limit,passthru,exec,system,popen,shell_exec,proc_open

jjk

#1
I think you have several (self-made) problems on your site. SEF urls are working very well using the original Joomla SEF urls. sh404sef is not required. Over time, it adds a huge amount of generated urls to a cache file which makes your shop slower. So I would suggest to build your shop without sh404sef, which afaik still achieves compatibility with VirtueMart by switching itself off (using the original VM router) on VirtueMart pages. If you uninstall or disabled it, you should also clear its cache folder.

Concerning your 'bug', I suppose it is mainly caused by a mismatch of your menus. The Joomla router needs Joomla menu and category ids to work correctly, and at a first glance it looks to me like you don't have a Joomla menu item for 'Murs d'images'.

Also, I noticed that your template is using external google fonts, which have to be loaded from Google. Often these don't work, which is why I see for example this error message: "NetworkError: 400 Bad Request - ...//fonts.googleapis.com/css?family=Viga:700&subset=Latin"
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

selor

Hi and thanks to read about my problem //
i am sorry to read everywhere on component dev forum that sef404 isnt working because it works better than original joomla one on many case ..but since i have sef404 my referencement and many rewriting problems works now perfectly .

For the problem itself the incredible think is that in my menu items i add them by the normal menu item creator using the virtuemart code itself if i am not wrong because you choose new menu item and choose to create the link trough Virtuemart .. category item view ..

so why did this simple code didnt make the same thing on all links ?? really amazing no because the only thing who change is the id of the category itself ..

so why did on some link it add this ?category layout option and sometimes not ??
so for me the problem is in this part only ..it seems wrong ?

if i deasactivate sef404 i have thousand other problem which appears .. sometimes the router take a link something like url /categoryname/subcategoryname/productname
sometimes it takes /categoryname/productname  ans its just a short example .. so thats why i am using sef404 .. to keep the integrity of url for a long time ..
thinks that virtuemart not make perfectly for the moment ..

so if youre just interesting in try figure out my problem than turn arround and go in a different way .. its not my attempt sorry but thanks to read me ..and time ..

ps: for the font i know thanks its in the way to be solve its not in the template but in a module menu who call this external font i will disable this .

Thanks
Production: Joomla 2.5.8 | VM 2.0.15d | PHP Version 5.3.19 Apache 2.0 Handler

Safe Mode : Disabled
Disabled Functions:set_time_limit,passthru,exec,system,popen,shell_exec,proc_open

jjk

I'm sorry, but I'm unable to sort out any problems which might be a result of sh404sef not working correctly with the Joomla and VirtueMart routers. I'm happy with the Joomla and VM SEF options, which allow to build any url I want using Joomla menus.  I've discarded sh404sef when Joomla 1.6 was released long time ago. Note that the important urls for the search engines are the canonical urls, which are produced by VirtueMart. I don't know if sh404sef sets a canonical tag, too.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

selor

ok so ... i assumed SEF404 is configured as this now :
Virtuemart using router of joomla and virtuemart ok ?
( I have deleted in the table of Url generated by Sef404 all that wad generated for the component Virtuemart ..

So now its only virtuemart router assisted by the joomla router if i understand all ?

So why these errors ?? :
Go on this link :
https://www.kubevent.fr/location/video/videoprojecteurs

There is projectors as products all in the same subcategory which are :  Video (TopLevelCat)==>Videoprojecteurs (SubCat1)==>Products in this subcat1  ok ?
Examine the links and you could see many problems .. :
https://www.kubevent.fr/location/dhd775-e-detail  ( Why did the routers dont make the good link ? which does be like this ? : /location/video/videoprojecteurs/  = aliasJoomlaMenu/ToplevelCat/SubCat1   ) ??
https://www.kubevent.fr/location/video/videoprojecteurs/hdf-w26-detail  (This one seems good but i wouldnt the add of this "detail" in the url which is off in the configuration ... so why is here ????)

and if you examine other categories it seems to be Random ...Amazing ..

For me its not Good ...

So i could imagine maybe its a problem of configuration i am ok to say maybe its me who generate a problem but Really ... i think many users search to have just something working normally with the rewriting of url in virtuemart ..

So i am waiting for a real Advice to have it working .. or my final choice will be just let Virtuemart and finally after 3 years .. change product ...

Thanks ..
And JJK thanks for the help ..



[attachment cleanup by admin]
Production: Joomla 2.5.8 | VM 2.0.15d | PHP Version 5.3.19 Apache 2.0 Handler

Safe Mode : Disabled
Disabled Functions:set_time_limit,passthru,exec,system,popen,shell_exec,proc_open

jjk

Looking at your current site, you have accumulated a lot of unnecessary stuff which will create problems. For example I can see 4! different versions of jquery being loaded. You should limit that to 1 (the one that comes with Joomla, which is also used by VirtueMart. Also I can see three lightboxes. I doubt that for example fancybox2 is compatible with VirtueMart (BTW - afaik the Fancybox 2 license doesn't allow commercial use. Did that come with your template?).
At present I would suggest that you unpublish/uninstall everything you don't really need in order to avoid conflicts between extensions.

Currently you also seem to have disabled the VirtueMart SEO-Suffix (default is '-detail'). If you do that, the VirtueMart router will produce errors. You can change it for example to '-htm' or '-html' if you like, but some kind of suffix is required to distinguish between VM category and product pages.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

selor

hi and thanks to help

QuoteCurrently you also seem to have disabled the VirtueMart SEO-Suffix (default is '-detail'). If you do that, the VirtueMart router will produce errors. You can change it for example to '-htm' or '-html' if you like, but some kind of suffix is required to distinguish between VM category and product pages

ah ok for this point i have readded the suffix Thanks.

For all the JS loaded it really hard sometimes to know by which extension its loaded .. its my case ..

QuoteI would suggest that you unpublish/uninstall everything you don't really need in order to avoid conflicts between extensions

I will try check but on my side really hard to understand who conflicts what ..



BUT .. it doesnt explain anything about the links created by the router no ?

look at there : https://www.kubevent.fr/location/ecran-led-prolite-22-pouces-detail
This product is under the same subcategory as other products ...
did you think that the links could be created by this error of JS ??

When i rename the html/com_virtuemart  dir in order to switch off the template the links are the same ..
so why or who make this bad links ?


I have update all the VM2 to 2.6.10 and problem still there ..
Production: Joomla 2.5.8 | VM 2.0.15d | PHP Version 5.3.19 Apache 2.0 Handler

Safe Mode : Disabled
Disabled Functions:set_time_limit,passthru,exec,system,popen,shell_exec,proc_open

jjk

#7
Quote from: selor on September 07, 2014, 12:06:00 PM
look at there ....kubevent.fr/location/ecran-led-prolite-22-pouces-detail

I'm not shure what you mean. Do you want the above url to look like this: kubevent.fr/location/video/videoprojeteurs/ecran-led-prolite-22-pouces-detail?
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

selor

the problem is that this link isnt correct

this product is under video/ecran-lcd/product

so where are all the category hierarchy of virtuemart on some links ? and other it respect it .. ???
Production: Joomla 2.5.8 | VM 2.0.15d | PHP Version 5.3.19 Apache 2.0 Handler

Safe Mode : Disabled
Disabled Functions:set_time_limit,passthru,exec,system,popen,shell_exec,proc_open

GJC Web Design

Are u certain sh404sef overblown resource heavy un-nesscesary component is disabled completely and all sef urls purged?

If you go to https://www.kubevent.fr/location/video/ecrans-led-lcd

the first 2 products are

https://www.kubevent.fr/location/ecran-led-prolite-22-pouces-detail
&
https://www.kubevent.fr/location/video/ecrans-led-lcd/ecran-led-prolite-27-pouces-detail

normal VM would produce the 2nd url - the 1st is odd and not normal vm behaviour

what are the non sef urls to these 2 products?
if you enable breadcrumbs what do the look like?

GJC Web Design
VirtueMart and Joomla Developers - php developers https://www.gjcwebdesign.com
VM4 AusPost Shipping Plugin - e-go Shipping Plugin - VM4 Postcode Shipping Plugin - Radius Shipping Plugin - VM4 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
https://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

jjk

Note: I updated my previous reply. Probably you need a different menu configuration. See here: http://forum.virtuemart.net/index.php?topic=117507.msg397009#msg397009
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations