Upgrade to 2.6.4 and no longer able to add child products

Started by roojai, May 27, 2014, 04:28:35 AM

Previous topic - Next topic


I was able to add child products without problem before but I recently upgraded to VM2.6.4 and also started to use two languages (not sure if related to languages). My Joomla version is 2.5.20

Now if I try to create a child product I get the message:

vmError: Database error: createChild Duplicate entry '1' for key 'slug' SQL=INSERT INTO `****_virtuemart_products_en_gb` (`virtuemart_product_id`,`slug`) VALUES ("0","1");
vmError: Database error: createChild Duplicate entry '1' for key 'slug' SQL=INSERT INTO `****_virtuemart_products_zh_tw` (`virtuemart_product_id`,`slug`) VALUES ("0","1");
Child product not created successfully

I cannot assign a different SKU or alias to the children as there is no opportunity - I can't even get to that point. I have tried to add child of old products, new products, different product names.....no luck.

Thanks for any help


Should I fix your bug, please support the VirtueMart project and become a member
Extensions approved by the core team: http://extensions.virtuemart.net/


I used that php file and replaced the existing one at domain/administrator/components/com_virtuemart/helpers but no better




OK, I have done some more testing/research. Just to determine if the problem is related to the upgrade or something else.

I had a copy of the site before the upgrade so I set that up on a test server. The old version was 2.026d and I tried to make child products.  No problem at all.

Then I carried out the upgrade to 2.6.4 without changing anything else on the site. Tried to make child products. First one was ok, but the product alias is "1". Then the next child I got an error warning about "Creatchild duplicate entry "1" for key 2". It did make the child product successfully though and created an alias of 1-1. Then next children were all 1-2, 1-3 etc, all with warnings.

Then back to the original site which has had 70+ child products created since upgrade. It is no longer able to make the child products at all - warnings for both language tables.

I also have another website running VM2.6.4 with single language only. I am not getting the errors on that site but the product alias of child products is 1, 1-1, 1-2, 1-3 etc.