Author Topic: server has had php upgrade - causing issues?  (Read 3028 times)

maxelcat

  • Beginner
  • *
  • Posts: 48
server has had php upgrade - causing issues?
« on: April 10, 2014, 15:11:04 pm »
Hi we have a joomla 1.5.26 running vm 1.1.4

Recently our server was updated to php 5.4 and we have noticed things not working - eg users when they click to register the form fields just empty and no emails are sent and no new user created. Existing users seem to be able to log in ok though and purchase

I would like to know is the php upgrade going to cause problems?

Thanks in advance!

E


JoomTut

  • Jr. Member
  • **
  • Posts: 64
    • How to Joomla!
Re: server has had php upgrade - causing issues?
« Reply #1 on: April 10, 2014, 17:57:51 pm »
You have 2 options:

1/ Edit your code to be compatible with the new version of php.

2/ Upgrade to the latest version of Joomla!
http://www.joomtut.com - How to Joomla!
Joomla! & VirtueMart Pro Support.
http://www.joomtut.com/joomla-clip.html - 14 steps to creating a Joomla! website with video clip tutorials

maxelcat

  • Beginner
  • *
  • Posts: 48
Re: server has had php upgrade - causing issues?
« Reply #2 on: April 10, 2014, 18:00:05 pm »
Thanks - but I know this already...

My question is really is the php upgrade going to be the cause of these problems.


jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28224
  • Always on vacation
    • Jenkin Hill Internet
Re: server has had php upgrade - causing issues?
« Reply #3 on: April 10, 2014, 18:18:37 pm »
See http://forum.virtuemart.net/index.php?topic=106865 from August 2012:

Quote
At some stage J1.5/VM1.1.9 will cease to work properly because of server updates. Host PHP version upgrades have already caused problems for some users and the finding that scripts run several times faster on PHP5.4/5.5 when compared to 5.2/3 may lead to pressure on hosts to update their versions, which is also important for security considerations. Some VM1.1 functions will cease to work under PHP5.4 and it most likely will not work at all under PHP5.5. (Added Jan 2014, hosts have started introducing PHP5.5 already).

Nobody can be sure that the pHP update is causing your problems, but it is highly likely. Maybe check the Joomla root directory for an error log file (error.php).
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.28 PHP 7.4.14