Support the VirtueMart project and become a member

Main Menu

Error after language change. (Not about missing categories.) SOLVED

Started by Amrachet, March 26, 2013, 21:39:06 PM

Previous topic - Next topic


after language change to Slovenian language VM is giving me some error. It is the same error no mater to witch language I switch. I created some categories in my original language and if I switch to that one everything is fine, but if I use some another language there is this error.

vmError: exeSortSearchListQuery Table 'nafe01_nova.gdhgc_virtuemart_categories_en_gb' doesn't exist SQL=SELECT c.`virtuemart_category_id`, l.`category_description`, l.`category_name`, c.`ordering`, c.`published`, cx.`category_child_id`, cx.`category_parent_id`, c.`shared` FROM `gdhgc_virtuemart_categories_en_gb` l JOIN `gdhgc_virtuemart_categories` AS c using (`virtuemart_category_id`) LEFT JOIN `gdhgc_virtuemart_category_categories` AS cx ON l.`virtuemart_category_id` = cx.`category_child_id` WHERE cx.`category_parent_id` = 0 ORDER BY category_name DESC

Can you tell me what to do?  :(


K&K media production

Do you have set up a category name for each language?

Go in Backend to each category, select the language from dropdown and save a name.


Quote from: kkmediaproduction on March 26, 2013, 22:00:24 PM
Go in Backend to each category, select the language from dropdown and save a name.

Sorry, but when I go to Categories and open one there is no language dropdown. There is Category Name, Published, Sef Alias, Description and then block with Details and Meta

Am I in a wrong section?

K&K media production

is your shop multilanguage?

vm creates for each language a own table. if your shop is not multilanguage and you change the main language, the language tables for this language are missing and the dropdown is not visible.

You must set up the languages in configuration before the dropdown is visible.

If you like to change the language global and you need only this one language, maybe you can go (i.e. with phpmyadmin) to your database and change the language tag of the tables.


PROBLEM SOLVED - After re-installation(update) of the VM it created new tables for new language.