"404 Not Found" when Use "URL rewriting" switched on in some cases

Started by isuv, February 01, 2013, 10:56:10 AM

Previous topic - Next topic

isuv

Hi everybody,

First I would like to thank you for all the help, that you providing in this forum.

I have a specific problem with Joomla 2.5.8 + VM 2.0.16. Joomla SEF is switched on. But when "Use URL rewriting" is also switched on I get  "404 Not Found" in the case, when I try to sort products by date of modification, for example. I get this:

Not Found
The requested URL /kategorii/katalog-lyustr/by,`p`.modified_on was not found on this server.


I don't get this mistake, when "Use URL rewriting" is switched off.

In connection with above mentioned I would like to ask what the promlem may it be and how to solve this. And I also would like to ask if it is necessary to use "Use URL rewriting" switched on?

franzpeter

I had that problem too. I think it happens, if categories are linked to a Joomla menu. There was one main category with the name and the slug 'notebook'. Using notebooks as name for the subcategory under the main category notebook did throw a soft 404 error. Same thing can happen, if a category is linked by a joomla alias link. For example: If the category notebook as root category contains notebooks, Pad PC a.s.o. the slug would normally be: notebook/notebooks or notebook/pad-pc. You have a second root category called bags for example with subcategories like notebook bag, mobile phone bag a.s.o, but you would like to put the bags as menu subcategory to the notebooks category the url would be notebook/bags. To prevent it you can create bags as a hidden menu and put Joomla alias into the notebook category tree. Advantage: the category bag keeps the original url. It shows /bags/... and not notebook/bags/.... But not so with the VM router. It obviously works sometimes and sometimes not, especially with the sort function it produces the soft 404 error. If a soft 404 error occurs and the joomla cache is activated (even if you tell it to not cache the menu), that error is shown until you clear the cache.
So for now the best way is to not use Joomla Alias with VM categories.

isuv

Quote from: franzpeter on February 01, 2013, 14:29:06 PM
I had that problem too. I think it happens, if categories are linked to a Joomla menu. There was one main category with the name and the slug 'notebook'. Using notebooks as name for the subcategory under the main category notebook did throw a soft 404 error. Same thing can happen, if a category is linked by a joomla alias link. For example: If the category notebook as root category contains notebooks, Pad PC a.s.o. the slug would normally be: notebook/notebooks or notebook/pad-pc. You have a second root category called bags for example with subcategories like notebook bag, mobile phone bag a.s.o, but you would like to put the bags as menu subcategory to the notebooks category the url would be notebook/bags. To prevent it you can create bags as a hidden menu and put Joomla alias into the notebook category tree. Advantage: the category bag keeps the original url. It shows /bags/... and not notebook/bags/.... But not so with the VM router. It obviously works sometimes and sometimes not, especially with the sort function it produces the soft 404 error. If a soft 404 error occurs and the joomla cache is activated (even if you tell it to not cache the menu), that error is shown until you clear the cache.
So for now the best way is to not use Joomla Alias with VM categories.

Hi franzpeter,
Thanks for your reply. What do you mean by "categories are linked to a Joomla menu". I have only associated shop with the main page menu item of my website. And I get error only in case of such links http://mysitename/kategorii/katalog-lyustr/by,%60p%60.modified_on (which appear, when I try to sort products on a webpage by date of modification, for example).

isuv

I've solved this by switching "Adds Suffix to URL" in the SEO settings (in Global Configuration of the website) to "yes".  :)

jbrailas

Quote from: isuv on February 01, 2013, 18:13:58 PM
I've solved this by switching "Adds Suffix to URL" in the SEO settings (in Global Configuration of the website) to "yes".  :)

Great, but this is only a work-around not a real fix...
Let's hope that it will be fixed in VM 2.0.21

keran


Milbo

I found the problem, happens if you use an ordering which has an `` in the link, then it does not work.
Should I fix your bug, please support the VirtueMart project and become a [url=http://extensions.virtuemart.net/support/virtuemart-supporter-membership-detail]member[/url]
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Xris75

Hi Milbo,

I take the opportunity to thank you first for the fantastic job;
I am running J 2.5.16 and VM 2.0.24; my expertise in VM is increasing but I still consider myself as a beginner

Could you specify what you mean by

an ordering which has an `` in the link

Where can I find that and change it ?

Best

Christophe