[SOLVED]No shipment method matches the characteristics of your order

Started by axcelia, January 18, 2013, 12:03:27 PM

Previous topic - Next topic


I am using Joomla 2.5 Virtuemart 2.0.18a
I recently migrated across from Joomla 1.5 and Virtuemart 1.

I'm in the process of setting up the payment and shipping and I've come across this error "We are sorry, no shipment method matches the characteristics of your order."
Here is a bit more information which will hopefully help narrow down the issue.

Shipment plugin "Vm Shipment plugin Weight/Nb of Products/Countries" is enabled (I double checked)
The migrated products never had a weight set apart from 0 and were left with the default weight measurement of pounds. They are all in the database as 0. I tried setting a weight to one of the products and setting it to use weight in the configuration but I still got this error message.
I setup the shipping method with the following configuration:

Countries: none selected (I tried selected UK but it still didn't work)
Zip Range Start: left blank (UK does not use zip codes)
Zip Range End: Left blank
Lowest Weight: blank (As I said tried setting this along with assigning a weight to a product but I still got this error)
Highest Weight: blank
Weight Unit: Pounds (I checked this is what all the products have stored in the database as default)
Minimum number of products: blank
Maximum number of products: blank (Again I have tried fiddling around with these settings I still got the error)
Minimum Order amount: blankl (Again tried setting this to a figure like 10 I still get the error)
Maximum Order amount: blank (see above)
Shipping cost: 6
Package Fee: blank
Tax: Apply no rule
Min Amount for free shipping: 50 (tried editing this).

I'm at a loss as to what is going on. I've used VM2 before and not had this problem so I suspect there is something funky going on caused by the migration.
Any help greatly appreciated.


Wow I feel an idiot. After typing all that out I suddenly had a brainwave when I remembered the trouble I had getting virtuemart to change the vendor.
The answer was the Vendor was setup wrong. I changed that and it now works. I shall change this to solved.


Please can you explain me the solution you found? I have the same problem.



This was awhile ago but I'll try and remember :)

If I remember correctly what had happened was that I had ended up with two vendor accounts because the new version of Virtuemart uses the default Super Admin as the vendor, but I needed a different account to be a vendor which meant I ended up with two and I had two options to choose from.

In the configuration I selected "Enable Multivendor" and set it to "administrated multivendor"
If you go into you shipment method you will now see an option to choose your Vendor. Select the correct one and save

That fixed it for me. You can turn off the Multivendor part afterwards and I also made sure to change the default Super Admin to not be a vendor, the other way is to change the default super admin into the vendors account and make a new super admin account for yourself (if you need to have a separate one).

I hope that wasn't too confusing, it was awhile ago I was going through this.


thank you for posting your fix - it really helped me out today  ;)


I faced with the same issue when installed VM 4.2.12.
In my case, I installed sample data and was not able to finalize the checkout due to the error:

We are sorry, no shipment method matches the characteristics of your order.

I added the 2nd shipping method and it could not help.
Then I removed the default Pick up point payment method and added it again with default settings.
It helped.

Thanks to Brad Markle - source.

I am posting this information here since other users can face with the same problem.

NorrNext - payment plugins and ecommerce solutions for Joomla components - https://norrnext.com
Stripe for VirtueMart - https://extensions.virtuemart.net/stripe-virtuemart-detail
Stripe Checkout for VirtueMart - https://extensions.virtuemart.net/stripe-virtuemart-detail