Author Topic: Uploading very large image for category image creates 500 internal errors  (Read 7487 times)

croppertiger

  • Beginner
  • *
  • Posts: 11
Just recently I broke my virtuemart site - the frontend worked, the cart worked, but clicking on any product or category would fail with 500 internal error.

The reason I found out was the image I attempted to upload for a category image was about 3mb. This broke virtuemart.

After deleting the category (as I couldn't click on it in the backend, as this produced a 500 internal error), the error was fixed.

I then had to create the category, upload a small pic for the image, and then re-set the products back to this category.

Hope that helps. I replicated this error on another virtuemart test site and it did the same.

Keep up the good work!

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: Uploading very large image for category image creates 500 internal errors
« Reply #1 on: November 07, 2012, 16:57:26 pm »
Hello,

This one have to do with your PHP settings and max upload size. An example configuration:

You could edit your php.ini file and import the following:

value upload_max_filesize 12M

If you don't have access to PHP configuration try to edit the htacaess file:
If you are using apache you have to rename the file to htaccess.txt .htaccess. Then under joomla global configuration you have to enable Use URL rewriting

After that edit your .htaccess and place the line:

php_value upload_max_filesize 12M

Depends on your needs

Regards
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: Uploading very large image for category image creates 500 internal errors
« Reply #2 on: November 21, 2012, 18:11:56 pm »
Some more configuration


Solution 1:
edit your php.ini file and import the following lines:

memory_limit = 128M;
max_execution_time = 300;
value upload_max_filesize 12M;

Solution 2:
1. If you don't have access to PHP configuration (php.ini file) and you are running apache as web server locate the .htaccess file in your joomla root folder. If the file does not exist rename the file in joomla root folder from htaccess.txt  to  .htaccess
2. Under joomla global configuration you have to enable Use URL rewriting
3. Edit .htaccess and place the lines:

php_value max_execution_time 300
php_value memory_limit 128M
php_value upload_max_filesize 12M

Solution 3:
If non of the above worked please contact your host provider and request to increase your php memory size limitation to at least 128mb

128MB is a good option running joomla 2.5 with/out Virtuemart 2

Extra Tutorial: http://wiki.opensource-excellence.com/index.php?title=Changing_PHP_configuration_setting

Regards
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!