[SOLVED] Myself - Manual update to 2.0.6 still showing 2.0.2

Started by status101, June 25, 2012, 17:44:46 PM

Previous topic - Next topic


Hi There,

I have attempted to update from VM 2.0.2 to 2.0.6 today, and it 'seems' to have worked at least to some extent – that is, some of my layouts have changed, my pricing disappeared from the cart ( got that back with the default_pricelist.php changes ) and I have several other issues but I am still in process of updating template files etc. and I think these are best addressed one at a time are more time searching the forums....

I did a manual update of VM by un archiving the files, and FTPing them to the site (without the install directory) then using the update tables in the tools section as I found described by Milbo.

I then did an install of AIO through the Joomla installer.  The site came up after a little fiddling, resetting a few options and setting the vmfiles directory.

I guess my first problem here is -  How can I actually 100% tell that the update has taken place.  I ask this as when I load VM in the back end, I still get the message


When I click this link I get:

Installed version 2.0.2
Latest version 2.0.6

I am pretty sure that I have updated as I got the issue with missing prices, add to cart popup issues ( both resolved ) but I am wondering how to tell for SURE and to get rid of the system thinking I am still in 2.0.2?  Have I missed something. ( I am wondering if this is causing other issues and would like to resolve it first before bothering anyone with other problems.

I really have searched the forum and I just can't find anything on this issue of diplaying the incorrect ( or correct ) version of VM, nor can I find anything other than that one page that tells me what version I am really running.

Any help / thoughts / links to other posts I have not found would be appreciated

Thanks in Advance


b]UPDATE: [/b]

Ok, so 11 people looked at this post by this stage, so perhaps others are interested, and as no one had replied, perhaps others are interested in what I did to fix it.

So, I tried a manual update using FTP (again)... I uploaded the files, less the install directory and updated the tables (all clear and updated).  Some of the updated code / effects of the code changes for 2.0.6 were visible but in the component backend it still showed V2.0.2 and I was still not 100% happy that I was getting all the changes.

In the end after updating my current Joomla to 2.5.6, I did a fresh install of Joomla 2.5.6 and VM 2.0.6 to a sub directory ( actually used a quick start from my template provider - Gavick )

I then logged into cpanel and used the file manger there to transfer the contents of folders below from the sub directory (fresh install) to the main directory (attempted FTP upgrade 2.0.2 to 2.0.6).

administrator/components/com_virtuemart and

Side note: /components/com_virtuemart_allinone is empty on fresh and old install?!? Guess it is meant to be.

Log out, log in ( don't know what you have to ) and whalla.... version 2.0.6 showing correctly.

In theory, this should be the same as FTPing, but for me, FTP took an hour and for the sake of perhaps one or two files that failed or corrupted or something, it was still showing that I was using 2.0.2.. Transferring under cpanel took half the time and worked.

I am guessing that perhaps ( someone correct me if I am wrong ) that this should also work if you were to upload the package, extract on the server and copy over the necessary directories.

Anyway, I hope this helps someone out there.

Thanks to those who read the original post.