You may pay someone to create your store, or you visit our seminar and become a professional yourself with the silver certification

Main Menu

Login requests after upgrading

Started by drizzt99, April 01, 2012, 11:00:59 AM

Previous topic - Next topic


I've upgraded VM to 2.0.2 from 2.0.1.
For some reason, it now asks me to login when I want to see inside the categories on front end.
Here's a link:
Try to enter a category and see what happens.
Any idea why this happens?

Added later:
Now I notice that even after I login and try to watch the products, I get  blank screen on the product page itself.


It looks like no one can enter your shop unless they are registered -

No public access --  all users must have a login - this might be in joomla setting.

Look in users User settings and see if public is ticked?

Try see if you can see an article in joomla - just as a test.


Thanks for the help.
You can enter the shop and see the categories (
It happens only when you click on a category.  Anyway, I can view articles as a guest.
And as I added - when I tried to login, I was able to see inside the categories, but single product view gave me a blank page (with all products).



Make sure that you do not have a shopper group against products - "leave that blank"

You are saying that you can login - and maybe as a test login you are not a certain shopper group.

Find one product and check that first.

**???? added later -- Did you update joomla too as there has been some issues with users there -- ? 


QuoteMake sure that you do not have a shopper group against products - "leave that blank"
What do you mean by that? All I did was upgrade. The site works fine with V2.0.1 on the non-test site:
It happened after the upgrade...
QuoteYou are saying that you can login - and maybe as a test login you are not a certain shopper group
I login as admin.
QuoteFind one product and check that first.
I tried to get into all of them - same result.


Ok, I'll try to re-install and let you know if it happens again.
One thing to make sure - VM2.0.1 doesn't work with J2.5, is that right?


There has been some issues with Joomla users over the past week.

I'm wondering if you updated joomla too. They were having issues with joomla users being locked out -. Or being unable to craete users.

maybe not a VM thing - Now I hear that Joomla might be doing an upgrade "Might " tomorrow with a large user issue -

* so Can you wait?

VM is now up to version 2.0.3 'H version - these are just test versions.

* user groupos - against products in the back end - not the front - check just one product and makes sure that - just one product has no user groups - as a test.


Yea, I'll wait for it.
You are right - I've upgraded to J2.5.  This is why I wanted to reinstall now.
I'm now installing VM2.0.2 on the J1.7 to see if it works. Then I'll wait for the new 2.5 update I guess...
Regarding 2.0.3 - when I download from the main website, I get 2.0.2.  So officially, 2.0.2 is the stable one, right? I should go with that for a livesite, correct?


Lots have small similar issues -

I hope Joomla fix the user issues and I hope it works for you as well as others -

I can't guarantee that they will update tomorrow  -but they "joomla"need to fix a major User bug.

Here's hopeing .

You can have a look at the joomla forums - and see what others are doing .



it is indeed a Joomla issue.
I just installed VM 2.0.2 and I can get inside a category.
When I try to view a product I get this:
Fatal error: Call to undefined method shopFunctionsF::PdfIcon() in /home/golly/public_html/test/templates/theme737/html/com_virtuemart/productdetails/default.php on line 55
I guess it means there's a difference in the versions - is that right? So I need to redo the template?


Yep just use a default template and test- see how you go .

the from there - test every thing and get a new updated template -

I actually liked your site and set out.


k, thanks :)
I hope that in the next versions I won't have to do it all over again :)


saw two possible solutions try these :

and joomla was just updated 2.5.4

let us know how you went .


I've upgraded to 2.5.4 now and it shows the login screen again when I try to enter a category.
Now I've found the problem. I enter the shop via a menu item called: "products".
For some reason, when I enter the categories/products, it changes the menu item to "promos".  I
So my shop address is:
And my products/categories address is like that:
(where XXX is a category/product suffix to the URI).

I have no idea why it is like that.  Is there some place to change "joomla menu item for shop" or something? Maybe something to do with the SEF feature?



It's like you have two shops in one and both are linking
* one in the public folder
* one in the test folder

* both linked to the same data base and then in menus you have linked both together ?

* you also have templates showing up in different places -

* I can't really figure out how you set this up.

Looks like you set the shop up in one folder and there is a VM shop there and then in 'Test' you repeated the same thing and linked menus.