VirtueMart Forum

VirtueMart 1.1.x [ Old version - no longer supported ] => Mambots, Plugins VM 1.1 => Topic started by: maemae on March 10, 2012, 17:45:10 pm

Title: virtuemart vmxsearch confusion! product description search? checkbox?
Post by: maemae on March 10, 2012, 17:45:10 pm
Joomla 1.5.4
Virtuemart 1.1.5

Ok. So I have the core Joomla search running on the site, which only seems to search within the content and also quite strictly (eg. apples would not return the word apple if that were in the text where appl would).
It doesn't even return results for some of the main menu items or direct children of my main menu. Just content. Although it thinks it searches all menus.
Well, I thought, I can cope with that if I had a product search.

(btw I tried installing the FLY06 search plugin to see if it improved my searches... it didn't but it did add a 'modules' checkbox to the search options... guess I have no searchable content in the modules... ooh, I thought, wonder if I can get a 'products' checkbox! unpublished it for now.)

Tried installing and enabling two different copies now (not simultaneously) of, both claimed to be enabled and working but there is no 'products' checkbox in search and no results for exact product names or three word entries, nothing. So basically it doesn't seemto have made a bit of difference.

Slightly beginning to tear out hair having perused the forums for days now only to find a few similar queries with no replies... apart from the odd 'so how did you fix it then?' a year or so later....

Somewhere I found something about how the templates for virtuemart can affect the search? the person who made the store had managed template on the main products and then when I look at categories there was managed on one and browse_1 on the other. tried changing them to see if they made any difference but they didn't make a difference to the way it looked or the search.

Squeak!! :-\
Title: Re: virtuemart vmxsearch search plugin not working at all boo hoo! please help!
Post by: maemae on March 17, 2012, 15:09:41 pm
ok sorted it out, client had no keywords in the short descriptions and it seems vmx search only searches short descriptions. Now that I can handle I suppose, just putting relevant search terms in the short description. But where is the product search checkbox? I had a wee look at components> com_search> views> search> tmpl> default.php and then got a bit scared. Not being a PHP whizz-kid myself I could do with some help...