VirtueMart Forum

VirtueMart 1.1.x [ Old version - no longer supported ] => Products, Prices, Tax and Categories VM 1.1 => Topic started by: rashmiranjan on April 02, 2010, 03:01:45 am

Title: Thumbnail not getting saved
Post by: rashmiranjan on April 02, 2010, 03:01:45 am
Hi,

I am trying to auto create thumbnails while uploading an image. However, it is not getting saved in the resized directory. The directory permission level is set at 777.

When I change the resized permission to 755. I get errors.
Code: [Select]
Warning: imagejpeg() [function.imagejpeg]: Unable to open '/public_html/components/com_virtuemart/shop_image/product/resized/LULU_GUINNESS_CA_4bb53fcf0b0ad_90x90.jpg' for writing: Permission denied in /public_html/administrator/components/com_virtuemart/classes/class.img2thumb.php  on line 299

Warning: getimagesize(/public_html/components/com_virtuemart/shop_image/product/resized/LULU_GUINNESS_CA_4bb53fcf0b0ad_90x90.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /public_html/administrator/components/com_virtuemart/classes/class.img2thumb.php on line 363

Warning: copy(/public_html/components/com_virtuemart/shop_image/product/resized/LULU_GUINNESS_CA_4bb53fcf0b0ad_90x90.jpg) [function.copy]: failed to open stream: No such file or directory in /public_html/administrator/components/com_virtuemart/classes/imageTools.class.php on line 331

I want the thumbnail to be saved with the same name as that of the product image but in the resized directory. With the above error message, it appears to be trying to save with a different name. The name of the image is in the format number.jpg.

What do I need to change to make it save in the directory and with the same name as that of the image in the product folder?

In the error above, I have removed the home and directory name for safety concerns.

Update: I tried saving from my desktop, and it does get saved. It is not saving from an external URL only. The image name is completely random and I got no clue how to get it.
Title: Re: Thumbnail not getting saved and created
Post by: psycofox on July 03, 2013, 11:10:44 am
I've the same problem, i upload the image but virtuemart not have created the thumbnails i don't now why.
Title: Re: Thumbnail not getting saved
Post by: apple78 on July 17, 2013, 10:02:46 am
hi, still ,I got some error while creating thumbnail (http://www.rasteredge.com/how-to/csharp-imaging/thumbnail-creating/) using  virtuemart  .But I haven't figure what really matter.
once I got it or solve it ,I will post the problem / solution here.






Title: Re: Thumbnail not getting saved
Post by: jacaboo on August 20, 2013, 04:59:57 am
The quality option edits a parameter in the function that creates thumbnails (http://www.rasteredge.com/how-to/vb-net-imaging/thumbnail-creating/), and it actually works. As you can see in your own site, the thumbs on the right are just fine. The problem with the biggest thumbs on the left may be due to the fact that the original images are smaller than the thumbs themselves. Having to resize and enlarge the images, they will obviously be of worse quality - and the fact that they're not created using a photo editing program but a library on a web server explains why they look so ugly. Try using bigger images as a basis, and let me know what happens. I do this almost daily. I use an imaging sdk (http://www.rasteredge.com/how-to/vb-net-imaging/imaging-processing/) which can create thumbnails found on the internet . Install it and it becomes a selectable processing option.Then you can create thumbnails in your image in any program at all, including Adobe Acrobat . Just open the images, select thumbnail,and follow the setps given in the sdk, the task will be finished in several seconds. if you haven't found a good choice , you can have a try. best wishes.