VirtueMart Forum

VirtueMart 2 + 3 => Virtuemart Development and bug reports => Topic started by: hk on May 20, 2014, 18:02:58 pm

Title: Country/State information not correct
Post by: hk on May 20, 2014, 18:02:58 pm
Hi,

Using VM 2.0.26d

I have registered an user by selecting Country: United Kingdom and State: Northern Ireland
Everything shows correctly in the Cart page.

In Cart page, I selected Add/Edit billing address information, selected Country as Turkey, State showed - Select -, as there were no states associated with Turkey. After clicking Save, the Cart page showed Country as Turkey and State as Northern Ireland, which is incorrect.

Once the user has selected a Country which has States and then changes to a Country which doesn't have States, the State value of previous country is used. I think this is a bug. Can you please confirm and let me know what should be the workaround solution for this.
Title: Re: Country/State information not correct
Post by: hk on May 26, 2014, 13:54:48 pm
I want to know if this is a bug.
If this is not a bug, I'll contact other thread to get the solution.
Please confirm.
Title: Re: Country/State information not correct
Post by: Milbo on May 27, 2014, 00:15:06 am
sounds like a bug, maybe fixed in vm3. It is very rare that it happens.
Title: Re: Country/State information not correct
Post by: klattr1 on May 27, 2014, 15:19:02 pm
Are you using the SSL Redirect plugin by chance?
Title: Re: Country/State information not correct
Post by: hk on May 27, 2014, 15:59:17 pm
I have not installed any extra plugins!
Title: Re: Country/State information not correct
Post by: hk on May 30, 2014, 12:06:57 pm
sounds like a bug, maybe fixed in vm3. It is very rare that it happens.

If I make the State field as Not Required, everything works fine.
However, if State field is marked as Required, there is a problem