VirtueMart Forum

VirtueMart 2 + 3 => Administration & Configuration => Topic started by: Pcwolf on August 09, 2013, 12:51:25 pm

Title: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 09, 2013, 12:51:25 pm
Hello,

If you go to a product then you see, Ask a question about this product.
They open the window, you can type the text etc...
When you will send the email then i getting this error:

SMTP serverfout: 5.7.1 : Sender address rejected: not owned by user info@.....

But the Standard joomla contact works, user registration email works, order confirmation works etc..
But the Ask a question about this product don't works.

Yes, i entered my email adres in shop settings...

VM version: 2.0.22a
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 09, 2013, 14:06:38 pm
SMTP serverfout: 5.7.1 : Sender address rejected: not owned by user info@.....
What is the problem? Why it's not owned?
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 09, 2013, 15:22:29 pm
SMTP serverfout: 5.7.1 : Sender address rejected: not owned by user info@.....
What is the problem? Why it's not owned?

What you mean, its now owned ?

I filled my webshop details, contact details. What more ?
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 09, 2013, 21:09:22 pm
I formated my previous post to show what I'm talking about.
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 10, 2013, 12:47:30 pm
Yes, i know. I filled all the details etc...

image: http://i44.tinypic.com/25q5892.png (http://i44.tinypic.com/25q5892.png)
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 10, 2013, 19:25:30 pm
I think "Sender address" is the option in Joomla configuration.
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 11, 2013, 09:47:16 am
Everything is filled in my joomla configuration, in the email settings from joomla etc...

Can you give some more clarity. If you said only the sender andres in joomla configuration then i don't understand what exactly you mean.
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 11, 2013, 11:16:03 am
I think you use smtp protocol to deal with emails.
This smtp protocol is used in your Joomla configuration (email section).
Your shared hosting service said that "Sender address rejected: not owned by user info@....."
Are VM email, Joomla admin email and email used in Joomla configuration the same?
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 11, 2013, 11:45:59 am
Yes, i use only 1 email for all.

Contact, orders mail are still working...
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: jenkinhill on August 11, 2013, 12:17:44 pm
The ask a question mail program in VM2.0.22a uses the store admin (vendor)  or the Joomla superadmin as the from address, depending on the config setting for "Use the vendor email address". The address of the enquirer is set as the reply-to address.  So either there is an issue with the smtp anti-spam controls on your server, a corrupt file,  or the information being sent to the server is incorrect. Do you have template overrides for the askquestion files, maybe from an older VM version?

What happens if you use Joomla's PHP Mailer instead of SMTP?
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 11, 2013, 12:36:56 pm
If i use Php Mailer then i getting spam in me mail boxes with a red box and with SMTP not.
I use for everything the same email.

Yes i have another versions of vm.
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 12, 2013, 15:18:10 pm
You could use Easy Calc extension to deal with spam. It's more friendly to email system solution then smtp antispam solution from some web hosting companies.
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 13, 2013, 10:07:43 am
The only EasyCalc that i can find is a Calculator module ?

http://extensions.joomla.org/extensions/financial/cost-calculators/22979 (http://extensions.joomla.org/extensions/financial/cost-calculators/22979)

ps,
I added all my products on my webshop. Now i need to fix this before i can start with selling  :-\
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 13, 2013, 11:12:31 am
My bad. Easy Calc Check Plus. Try it.
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 14, 2013, 10:10:03 am
Doesn't work. I tried it. Enabled it for virtuemart. Same error  :(
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 14, 2013, 22:15:33 pm
You didn't understand me. Use Easy Calc Check Plus as antispam tool while you are sitting on Php Mailer.
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 15, 2013, 09:44:06 am
I tried it!

I getting same errors and i can't register, they say. Username, password and email error...
When i try again with SMTP then it works.
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 15, 2013, 10:49:03 am
If i use Php Mailer then i getting spam in me mail boxes with a red box and with SMTP not.
So your Php Mailer don't work any more? Ok.
So either there is an issue with the smtp anti-spam controls on your server...
Did you try to turn off smtp anti-spam on your shared web hosting service? Maybe it's gray listing option in your email box settings.
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 15, 2013, 11:50:31 am
I have 2 hostings.

One hosting for website and another email hosting.
I have Open xChange from Namecheap.

I will contact the hosting, hope it will help  :-\
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 15, 2013, 14:04:13 pm
Email hosting said, that namecheap don't use that option.

But i have found the problem.

In joomla Global settings. When i leave the textbox empty then it works (ask a questions about...)
But the contact, registration etc... are not working.
I getting this error in my mail hosting:

Quote
Could not deliver message to the following recipient(s):

Failed Recipient: info@....
Reason: Remote host said: 553 5.7.1 <info@.....>: Sender address rejected: not logged in

And if i fill the SMTP username and password then the registration, contact form... works

So, without SMTP username, the ask a question... works
But the user registration, contact.. are not working  :-\
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 15, 2013, 15:18:05 pm
I have 2 hostings.

One hosting for website and another email hosting.
'Another email hosting' is not typical case.

What is your web site url?
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 15, 2013, 16:00:19 pm
I have 2 hostings.

One hosting for website and another email hosting.
'Another email hosting' is not typical case.


Why not  :o
You can have example a shared hosting and email hosting. But in my hosting i don't like the email, so i have another email hsoting.

.. is site url.
(Are already above in the pic)
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Maxim Pishnyak on August 15, 2013, 19:13:18 pm
Could you see what mail method use Ask question? Could it be Php Mailer?
Title: Re: Ask a question about this product - Email Sending not working (Error)
Post by: Pcwolf on August 16, 2013, 09:43:01 am
No, because joomla contact, user registration... are not working. I got a message in my mail server:
"Site Administrator@missing_domain" and its spam.