VirtueMart Forum

VirtueMart 2 + 3 => Administration & Configuration => Topic started by: knutmw on October 01, 2012, 17:11:11 pm

Title: Edit screen i VM admin not working right
Post by: knutmw on October 01, 2012, 17:11:11 pm
Hi

First of all here is the verson number

VM: 2.0.10
Joomla: 2.5.6

I am trying to help somebody, that have upgraded from VM:2.0.02 to VM:2.0.10
Thay have also installed some language packs. This i have removed until we figure out the problem.

The problem is that when I in administrator site is trying to edit a product or changing a catagory. The site display all wrong.

Looks like all formatting av the layout not there, and the main edit window now showing at all. This is happening when i try to edit at product or a category Or trying to chage store settings. Same error.

Is there anybody out there that have some tips for me to figure this out?

I am new to joomla 2.5 and Virtuemart 2.0 I am normaly working in joomla 1.5 and Virtuemart 1.1.9

So  i hope to get som pointers om how to fix this.

Hope to here from somebody soon, since its a live site at those i am helping having some problems using it.
I know that they shoulnd upgraded a live site, but that is the case here i am afraid.

See attachment !!

[attachment cleanup by admin]
Title: Re: Edit screen i VM admin not working right
Post by: jenkinhill on October 01, 2012, 18:39:14 pm
Looks like a bad installation - what is the PHP version?   

Make a copy with Akeeba and install in localhost (or a subdirectory of the server) and reinstall the 2.0.10 VM component and the 2.0.10 AIO component over the files that are there using Joomla's extension installer. It will not wipe the database/images etc.
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 01, 2012, 18:45:49 pm
The php verson is 5.3.3-7+squeeze14

Is it posibel to downgread it?

At the moment i only have access to administator site. No ftp og DB connection.

Akeeba is the backup tool right?

Cant find the Akeeba too in admin, is this a compnent i have to download and install?

Sorry for this dumb questions but it my first day looking av virtuemart 2 and joomla 2.5 normaly work on virtuemart 1.1.9 and joomla 1.5
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 01, 2012, 19:16:17 pm
Tryed installing the virtuemart 2.0.2 and then upgrade again to 2.0.10 still same problem.

As i was told he upgreaded from the verson 2.0.2 to 2.0.10 last week. and when i tryed to edit product today he could not get in.
As you can see from the attachment.

Same issue show up when trying to edit a category or changing shop settings.

Can it be som premission setting ? Looks like when the site is going to "edit" mode it's not working.
Title: Re: Edit screen i VM admin not working right
Post by: bytelord on October 01, 2012, 20:05:23 pm
Hi,

Bad installation i suppose as jenkinhill mention. Try download from the above link the tar.gz files and upgrade manually from extension manager... be sure that you will upgrade both AIO and VM core. First take a full backup using akeeba, try also to install on local host xammp or wamp (PHP 5.3.x).

http://dev.virtuemart.net/projects/virtuemart/files

Regards
Title: Re: Edit screen i VM admin not working right
Post by: jenkinhill on October 01, 2012, 20:31:36 pm
Get Akeeba from https://www.akeebabackup.com/  - it is the only really essential tool for all Joomla users
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 01, 2012, 21:19:45 pm
Hi

I have tryed installing the  tar.gz file set. The instalation goes good. But still the same error.

Can it be a language problem? The owner of the site installed norwegian language files also?

Tryed installing them also from the beginning no error there also.

I am just not verry well knowen inside joomla 2.5 and virtumart 2.0

Is there anybody there that can help me look inside the admin site?

Akeeba is installed, and backup taken.
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 01, 2012, 22:56:23 pm
When clicking a product i get this url.

www.mysite.com/administrator/index.php?option=com_virtuemart&view=product&task=edit&virtuemart_product_id=7514&product_parent_id=0

It there something worng with the URL? Witch files are loaded to show this site? Witch files containing the "problem"

Tryed downgrading now to 2.0.8e but no luck whit that. Stile same problem. Dosen't matter what i do. I have tryed

2.0.2
2.0.4
2.0.8c
2.0.8e
2.0.10

Have noe upgraded joomla to 2.5.7

Still same problem.

O my god its frustrating. Can it be a DB error?

Can it be something else than upgrade issue? Since it's same problem anyhow?

Title: Re: Edit screen i VM admin not working right
Post by: bytelord on October 02, 2012, 01:01:06 am
Hi,

Can you take a backup with akeeba and try it locally with xampp or wamp and PHP 5.3.1?

Could you take a look inside joomla error log file?
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 03, 2012, 16:10:33 pm
I am starting to get frustrated over this problem now.

We have put in an older backup of all files that worked at the time i was in use.

We have put in an older backup of the database that worked at the time.

Still same error.

We are now back to
Joomla 2.5.6
VM 2.0.2

Joomla error log says noting intersting about what can be this problem. Only a bunch log inn errors

The site get blank with only the left meny when clicking on this menus in virtuemart.

- When clicking on a product to edit it. Standing in the product menu
- When clicking on a product to edit it. Standing in the inventory menu
- When clicking on a category name to edit it.
- When clicking on a manufacture to edit it
- When clicking on shop to edit shop details
- When clicking on a shopper feilds to edit
- When clicking on a order status feild to edit

Everything else is working like it should.

So what can cause this problem all of a sudden?

Hopeing on some great suggestions :-)


Title: Re: Edit screen i VM admin not working right
Post by: bytelord on October 03, 2012, 18:04:54 pm
Hi,

Can you take a backup with akeeba and try it locally with xampp or wamp and PHP 5.3.1?

Could you take a look inside joomla error log file?

Did you try that?

May be there are issues with your server configuration made by your hosting provider. Please try it a local installation. As you mention, you are not even have access with ftp, so may be the vm installation never took place on the right way!!

Regards

Regards
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 03, 2012, 19:21:43 pm
Hi

I have now every possibel access to the site i am testing.

I have FTP, SQL, controll panel and administror access to the site. The backup placed back on the server was an working one 2 weeks ago.

Have now just tested i local as you told me to do. Downloaded an akeeba backup file installed it local and tested
Ist the same there.

So i realy don't know anything more than this have to be something verry strange?

Where is it most possibel the error is?

IS it the php verson? is it in the SQL database?
Is it in some of the php files?

The local site is haveing this configuration

PHP 5.4.7
DB verson 5.5.27

If you want me to test with different php versons how do i change them on XAMPP?






Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 03, 2012, 19:27:40 pm
Can this be a language issue?

When looking inside the DB tabels i see virtuemart products tabels

And i see that there are 2 tabels one for norwegian and on for english.

All the norwegian ones is empty.

The administrator site and the main site i set to english. So it should reffer to that language, but was thinking it can be somethinge here? Since this is somehow related to where the errors take place?

Title: Re: Edit screen i VM admin not working right
Post by: bytelord on October 03, 2012, 20:06:47 pm
Hello,

I am suggesting PHP 5.3.x, 5.4 is very new and joomla itself has issues. Also try from the backend under tools->tools and migration-> install tables and if necessary update them
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 03, 2012, 21:18:15 pm
How to change the php verson on the local server? XAMPP v3.1.0

Tryed the utdate tabel in admin on the online shop, didn't work. Going to test i localy now, when i can change the php verson.
Title: Re: Edit screen i VM admin not working right
Post by: bytelord on October 03, 2012, 21:26:07 pm
you could download an older version of xampp from sourforge or a portable one with older versions having PHP 5.3.x

like this,

http://sourceforge.net/projects/xampp/files/XAMPP%20Windows/1.7.4/
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 03, 2012, 22:11:34 pm
Now i have downloaded the verson you say, tested it on that.

Still same errors

I have now installed the backup thats form when the time the site was working, at least is what i have been told. Doing this for somebody else.

Now with php 5.3.5

Also tested install tebles or if necessarty update them, and still no luck

I am just puzzeld what this can be.

I am now at virtuemart 2.0.2 and joomla 2.5.6

Title: Re: Edit screen i VM admin not working right
Post by: jenkinhill on October 03, 2012, 23:25:07 pm
PHP 5.4.7
DB verson 5.5.27

Joomla 2.5 will not work on these versions, and neither will VirtueMart 2.0.10 

Aim for PHP 5.3.13 and MySQL around 5.1
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 03, 2012, 23:35:24 pm
Have just testet it on php 5.3.4 and 5.3.5

I think that i have bene in the most php versons.
But stll same problemstilling like before



- When clicking on a product to edit it. Standing in the product menu
- When clicking on a product to edit it. Standing in the inventory menu
- When clicking on a category name to edit it.
- When clicking on a manufacture to edit it
- When clicking on shop to edit shop details
- When clicking on a shopper feilds to edit
- When clicking on a order status feild to edit

Get errors when useing joomla 2.5.6 and 2.5.7
And virtuemart 2.0.2 and 2.0.10 and 2.0.8c and 2.0.8e

Tryed all vm versons on both joomla versons.
Title: Re: Edit screen i VM admin not working right
Post by: bytelord on October 04, 2012, 01:53:10 am
Hello,

You are doing something wrong i suppose, or something is corrupted with your initial installation of joomla or virtuemart.
Try a clean installation with joomla 2.5.7 and vm 2.0.10, after you finish try to migrate your data manually or by using csvi.
Title: Re: Edit screen i VM admin not working right
Post by: jenkinhill on October 04, 2012, 11:01:47 am
Additionally you could make a fresh Joomla2.5.7/VM2.0.10 installation and then connect it to a copy of the current site database. The errors you see are most likely due to file corruptions rather than db issues. If that seems to work then copy over the image directories as well.
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 04, 2012, 17:28:42 pm
Hi

I now know for a fact is has to be det database

I have tested it like you sayd i tryed copying files from new instalation that works to the "Problem" instalation" that made no differens did still not work.

Then i tested the old DB on the working shop configuration. I got the same problem. So it looks like its something to de with the database.

How to find out and how to correct? Where can i be?

Title: Re: Edit screen i VM admin not working right
Post by: bytelord on October 04, 2012, 21:33:45 pm
Hello,

I cannot tell you how "damage" or not "damage" your database is.
What i am suggesting is to install a clean joomla 2.5.7, clean virtuemart 2.0.10. Configure your shop as was before, bring your templates. So now we have the site without the data. After that make a good backup with akeeba to the new site so if something goes wrong after you will have your site. So now the only thing that remains is the data and the file images!

Next step i am suggesting to use csvi to export your products from your working installation and the import them to your new clean installation. Last bring your media and make all the other necessary changes. After that sync your media if it is necessary.

It will take some time to accomplish but always take a backup first do not start from the scratch!!

Regards
Title: Re: Edit screen i VM admin not working right
Post by: knutmw on October 04, 2012, 23:39:13 pm
Yes i know

Have sendt an request to the hosting company and hope that thay can help me with a backup thats not to old of the database that are working. Will lose some date, men guess thats quick if it works.

Tanks for all the help so fare. Looks like i am going to install joomla 2.5.7 and VM 2.0.10 myself and upgrade my store form joomla 1.5.26 and VM 1.1.9

Have a nice day