Author Topic: Bug at edit categories?  (Read 1412 times)

fernandok

  • Beginner
  • *
  • Posts: 2
Bug at edit categories?
« on: March 06, 2012, 02:22:06 am »
Firstly, sorry my bad English. Secondly, i have searched for this bug and do not found anything similar.

I use VM 2.0.0.

At Administrator, when a click edit product categories, some opens the wrong category. Example:
Click the category "Jaquetas" open the URL:
http://www.xxx.com.br/administrator/index.php?option=com_virtuemart&view=category&task=edit&cid=2
Click the (sub)category "Riffel" open the URL:
http://www.xxx.com.br/administrator/index.php?option=com_virtuemart&view=category&task=edit&cid=20
Click the (sub)category "Ixon" open the URL:
http://www.valecross.com.br/administrator/index.php?option=com_virtuemart&view=category&task=edit&cid=22
But the same link looks like editing "Jaquetas", same data at both links.

That situation is doing a crazy result at my data, when users using the system.

Again, sorry my bad English. Please help.
I've tried to update but the server do not support most than 30 secconds execution time. If the bug is old and the update will solve, i will force update someway.

fernandok

  • Beginner
  • *
  • Posts: 2
Re: Bug at edit categories?
« Reply #1 on: March 07, 2012, 00:14:15 am »
Using the checkbox + Edit button works!

I believe this bug have caused a integrity problem at my database. Some (sub)categories just not appear, but at product list, the "product categories" column show them. By clicking in the link in that column in the product list, the category edit works well!

So I discovered the URL difference:
Not work -> http://xxx/administrator/index.php?option=com_virtuemart&view=category&task=edit&cid=24
Work -> http://xxx/administrator/index.php?option=com_virtuemart&view=category&task=edit&cid[]=24

I solved the problem editing the file:
administrator/components/com_virtuemart/views/category/tmpl/default.php
at the line 84, adding the "[]" to the URL:
Code: [Select]
$editlink = JRoute::_('index.php?option=com_virtuemart&view=category&task=edit&cid[]=' . $cat->virtuemart_category_id);
I hope this is the origin of the integrity problem, that I am doing a manual adjust now.

Again, sorry the bad English.