Author Topic: Ja Slideshow not working vith Virtuemart because of jquery  (Read 2879 times)

Adrian Cumpanasu

  • Beginner
  • *
  • Posts: 10
    • Free Photoshop Templates
  • Skype Name: adi.cumpanasu
Ja Slideshow not working vith Virtuemart because of jquery
« on: February 23, 2012, 14:39:58 pm »
I have JA SLIDESHOW on the main page of my site: www.adline-solutions.ro The main page is Virtuemart home page. JA SLIDESHOW works only if I delete jquery.min.js from components/com_virtuemart/assets/js.
It took me months to track the problem. I know the cause but I don't know the logic.

If I delete or rename jquery.min.js I cannot edit virtuemart products anymore.
free Love PSD: digitalprimes.com

scripcode

  • Beginner
  • *
  • Posts: 12
Re: Ja Slideshow not working vith Virtuemart because of jquery
« Reply #1 on: February 23, 2012, 17:27:28 pm »
are you use template base on T3 framework?

archos

  • Beginner
  • *
  • Posts: 33
Re: Ja Slideshow not working vith Virtuemart because of jquery
« Reply #2 on: February 23, 2012, 19:26:49 pm »
Again a javascript conflict...
have a look here -> http://forum.virtuemart.net/index.php?topic=95979.0

Just for info, phoca gallery slideshow works with VM2 and also have a possibility to link picture to a virtuemart product

Adrian Cumpanasu

  • Beginner
  • *
  • Posts: 10
    • Free Photoshop Templates
  • Skype Name: adi.cumpanasu
Re: Ja Slideshow not working vith Virtuemart because of jquery
« Reply #3 on: February 24, 2012, 10:40:38 am »
thanks a lot, guys. I will try the Phoca Slideshow.
But I see there are many versions of Phoca Slideshow. I don't knoe wich one is the one for virtuemart. Anyone has a link?
free Love PSD: digitalprimes.com

janssenrik86

  • Beginner
  • *
  • Posts: 4
Re: Ja Slideshow not working vith Virtuemart because of jquery
« Reply #4 on: April 23, 2012, 17:09:48 pm »
When you use a template of Joomlart with T3 support, you can fix your problem:

Go to your template in the backend of joomla
>>
You see the options 'Optimize CSS' and 'Optimize JS'.

Set:
Optimize CSS to 'Join & minify'
Optimize JS to 'No'

Problem was solved!!!