Author Topic: Errors after installation  (Read 9989 times)

lime21

  • Beginner
  • *
  • Posts: 7
Errors after installation
« on: February 17, 2012, 22:47:50 pm »
Hello,
I installed joomla 2.5.1 and after that virtuemart 2.0.0, nothing else.
I installed these local with xampp 1.7.7 on a linux-system.
After installing I get in the backend on virtuemart the following errors:

Code: [Select]
Strict Standards: Non-static method VmConfig::loadConfig() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/admin.virtuemart.php on line 20

Strict Standards: Non-static method VmConfig::setStartTime() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/helpers/config.php on line 169

Strict Standards: Non-static method VmConfig::setdbLanguageTag() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/helpers/config.php on line 395

Strict Standards: Non-static method VmConfig::showDebug() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/helpers/config.php on line 120

Strict Standards: Non-static method VmConfig::get() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/helpers/config.php on line 247

Strict Standards: Non-static method VmConfig::showDebug() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/helpers/config.php on line 120

Strict Standards: Non-static method vmJsApi::jQuery() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/admin.virtuemart.php on line 38

Strict Standards: Non-static method VmConfig::get() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/helpers/config.php on line 780

Strict Standards: Non-static method VmConfig::get() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/helpers/config.php on line 785

Strict Standards: Non-static method vmJsApi::jSite() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/admin.virtuemart.php on line 39

Strict Standards: Non-static method VmConfig::get() should not be called statically in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/helpers/config.php on line 833

Strict Standards: Non-static method AdminUIHelper::startAdminArea() should not be called statically, assuming $this from incompatible context in /opt/lampp/htdocs/mypage/administrator/components/com_virtuemart/views/virtuemart/tmpl/default.php on line 23

What is wrong? I couldn´t find something needful with a search enginge..

Regards

lime

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28308
  • Always on vacation
    • Jenkin Hill Internet
Re: Errors after installation
« Reply #1 on: February 17, 2012, 23:50:35 pm »
Turn off PHP error reporting in php.ini. It is commenting on standards....
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.28 PHP 7.4.14

lime21

  • Beginner
  • *
  • Posts: 7
Re: Errors after installation
« Reply #2 on: February 18, 2012, 09:43:46 am »
OK so I don´t have to be worry about these errors :-)

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28308
  • Always on vacation
    • Jenkin Hill Internet
Re: Errors after installation
« Reply #3 on: February 18, 2012, 12:24:00 pm »
They are not errors, but notices/advice about standards....

Unlike earlier version of PHP. version 5.3 onwards has error reporting turned on by default, where previously it was off. Most reliable web hosts turn off notice reporting and just leave it set to report real errors.

You can also change the level of error reporting in Joomla 2.5.1's Global configuration / Server / Server settings
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.28 PHP 7.4.14

lime21

  • Beginner
  • *
  • Posts: 7
Re: Errors after installation
« Reply #4 on: February 19, 2012, 09:55:46 am »
OK thank you very much, I understand  :)