Author Topic: When changing the website language, virtuemart does not work  (Read 28005 times)

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3534
  • using Matomo instead of Google Analytics
Re: When changing the website language, virtuemart does not work
« Reply #15 on: August 08, 2012, 17:39:56 pm »
Looks to me like you still don't have the Joomla language switcher on your homepage.
Perhaps this helps: http://www.joomla-css.nl/index.php/nl/module-stijlen-nl-16/taalkeuze-nl-16
Did you try the "Multilanguage Status" module in Joomla already? If not, go to 'Extensions' - 'Module Manager' - switch from site to administrator in the filter dropdown list and publish 'Multilingual Status'. Thereafter you can click on "Multilanguage Status' in the upper right menu line. Everything should be green there.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

sendanor

  • Beginner
  • *
  • Posts: 7
Re: When changing the website language, virtuemart does not work
« Reply #16 on: August 08, 2012, 17:45:53 pm »
Pffff.....at last, I got myself the solution:

like stated in the post https://forum.virtuemart.net/index.php?topic=104885.0 , the job was done by first transferring all .ini files connected to virtuemart in the MyWebsite/administrator/language/nl-NL and MyWebsite/language/nl-NL maps from the previous installation on http://lindamanya.com/index to my pc:

then I copied these .ini files in their respective MyWebsite2/administrator/language/nl-NL and MyWebsite2/language/nl-NL maps....job done, everything in both the frontend and backend finally appears in Dutch!!!

Hope this will help other people too, and that it my result in getting updates to language-packs for the Virtuemart community that solve this, as I may call it, bug.

sendanor

  • Beginner
  • *
  • Posts: 7
Re: When changing the website language, virtuemart does not work
« Reply #17 on: August 08, 2012, 17:48:19 pm »
Pffff.....at last, I got myself the solution:

like stated in the post https://forum.virtuemart.net/index.php?topic=104885.0 , the job was done by first transferring all .ini files connected to virtuemart in the MyWebsite/administrator/language/nl-NL and MyWebsite/language/nl-NL maps from the previous installation on http://lindamanya.com/index to my pc:

then I copied these .ini files in their respective MyWebsite2/administrator/language/nl-NL and MyWebsite2/language/nl-NL maps....job done, everything in both the frontend and backend finally appears in Dutch!!!

Hope this will help other people too, and that it my result in getting updates to language-packs for the Virtuemart community that solve this, as I may call it, bug.

Henrik Holm Nielsen

  • Jr. Member
  • **
  • Posts: 72
Re: When changing the website language, virtuemart does not work
« Reply #18 on: September 19, 2012, 18:35:04 pm »
I've had the same issue. Your can export the files form the SQL database.
After that ive edited the output in notepad and changed the table names like this
Tabelstructuur voor tabel `(prefix)_virtuemart_categories`to `(prefix)_virtuemart_categories_nl`
Make sure you change al the tables names using the search function and search for  "virtuemart_categories"


MaHe29,

Many thanx for this tip - worked like a charm ;)
/Zorroson :)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Billigt og professionelt design af din hjemmeside | Brug for en billig, flot og professionel hjemmeside?