Author Topic: Migrated from 1.1.9. Parent/Child Product Structure not migrated.  (Read 1968 times)

thesilentman

  • Beginner
  • *
  • Posts: 8
Hello Max & Co,

I just did a test migration from 1.1.9 to 2.0RC [H]. (Running on J1.5)

Unfortunately the parent/child structure was not migrated, so all products are all on the same level now.

I have not found a way to assign existing products as children to an existing parent.

What am I missing?

Thank you very much,

Frank

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9911
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Migrated from 1.1.9. Parent/Child Product Structure not migrated.
« Reply #1 on: October 14, 2011, 14:01:33 pm »
Heyhoo, I am sorry answering so late, I missed your post.

Yes you are right, this connection is missing in the migrator. It is connected to the problematic with product variants, producttypes and things like this, which are now represented as custom fields.

The parent/child relation was afaik done different in vm1.1 than in vm2, we have to take a closer look on this.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Bruce Morgan

  • Full Member
  • ***
  • Posts: 672
Re: Migrated from 1.1.9. Parent/Child Product Structure not migrated.
« Reply #2 on: October 14, 2011, 19:40:31 pm »
There is one other thing to consider.  When i changed my products structure so that included parent /child relationshuips it completely screwed up product sales tracking in Google Analytics.  If i had known this would occur I probably would have left it the way it was before.  Right now the only product detail viewable in GA are thiose do do not have children(or parents).

I do not mind rebuilding the whole structure again if need be, if the new structure will pass through the product information to GA.  Is this concern even on your radar screen at this stage?

Bruce
www.pepper-passion.com

thesilentman

  • Beginner
  • *
  • Posts: 8
Re: Migrated from 1.1.9. Parent/Child Product Structure not migrated.
« Reply #3 on: October 23, 2011, 13:01:39 pm »
Sorry Max I also missed your post.
Actually I was not informed by the forum software via mail, so I just checked today if anything new has developed and saw your post.

Has any of this been fixed in the latest "J" Version? Should I try a new install and migration, or lave it for a later version?
My situation is the following.
I am developing a site for a little time ow, and it was on J1.5 because of VM and another component. However the other component has also upgraded to support J1.7, so I was wondering if I can get VM2 correctly running on J1.7.

The stopping points are:

- Change of Templating (As I have read in the forum, it's not compatible with the VM1 Templates. but I can dive into the code and fix this)
- This thread's Parent/Child Issue.

Do you have any idea on when this thread's issues will be solved?

Thanks a lot.

Frank

Florentp

  • Jr. Member
  • **
  • Posts: 86
Re: Migrated from 1.1.9. Parent/Child Product Structure not migrated.
« Reply #4 on: January 28, 2012, 16:03:10 pm »
Hi !
Is there any news about that issue ?
Because i've the same problems... But with 30.000 products :/

Thanks :)

Florent
Web programmer. Passionate.
PHP, SQL, Javascript, JQuery, css.
Skype : florent.indienboutique