Author Topic: [Solved] Image upload - Large Image doesn't show  (Read 9707 times)

nflmerch

  • Jr. Member
  • **
  • Posts: 114
[Solved] Image upload - Large Image doesn't show
« on: January 24, 2012, 23:21:59 pm »
J1.7
I've tested on two different sites, VM2.0.0  and the SVN revision 5318 with the same results:

When uploading a product image in VM admin, only the thumbnail shows up in both the front end and the back end.
The image is there in the correct folder and has full privileges.   The link URLs appears to be pointed to the file, but the image does not show up.
Even when I copy the direct URL of the uploaded image into my web browser, I get a 500 error. 
However, I can successfully navigate to any other image URL that I did NOT upload through the VM admin.

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10338
  • VirtueMart Version: 3+
Re: Image upload - Large Image doesn't show
« Reply #1 on: January 24, 2012, 23:31:55 pm »
go into "shop media files" and make sure all images are published
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

nflmerch

  • Jr. Member
  • **
  • Posts: 114
Re: Image upload - Large Image doesn't show
« Reply #2 on: January 24, 2012, 23:41:29 pm »
Yes they are.  I also just updated to VM2.0.1b

nflmerch

  • Jr. Member
  • **
  • Posts: 114
Re: Image upload - Large Image doesn't show
« Reply #3 on: January 24, 2012, 23:45:15 pm »
When I use the admin "shop media files", and click on the image thumbnail so it opens a light box, I get this message:

"The requested content cannot be loaded.
Please try again later."

All my 8,000 images load correctly in the light box with images that I migrated from VM1, but not new images I just uploaded in VM2 admin

nflmerch

  • Jr. Member
  • **
  • Posts: 114
Re: Image upload - Large Image doesn't show
« Reply #4 on: January 24, 2012, 23:47:28 pm »
Please note, I don't believe it's a publishing issue, because the image will not load even when I go to the direct URL:

The image is there in the correct folder and has full privileges.   
Even when I copy the direct URL of the uploaded image into my web browser, I get a 500 error. 

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10338
  • VirtueMart Version: 3+
Re: Image upload - Large Image doesn't show
« Reply #5 on: January 25, 2012, 00:00:05 am »
are they "gif" files?

I had problems before with this on my 1.1 site. THE image was actually there, but would 500 error every time. I did think before it was mainly "gif"
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

nflmerch

  • Jr. Member
  • **
  • Posts: 114
Re: Image upload - Large Image doesn't show
« Reply #6 on: January 25, 2012, 00:32:17 am »
I tried a fresh install of both joomla 1.7 and VM2.0.1b , WITHOUT migrating my products and images from VM1 and it works fine.
So I will have to do more testing to see what the problem is.
I fear that most people do not have 8,000 products and 16,000 images like I do, so I am running into uncharted problems  (such as http://forum.virtuemart.net/index.php?topic=96722)

But to answer your question, I've been trying mostly jpg but I also tried png and gif

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9853
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Image upload - Large Image doesn't show
« Reply #7 on: January 25, 2012, 13:26:24 pm »
Even when I copy the direct URL of the uploaded image into my web browser, I get a 500 error. 

Please give an example of this URL (relativ). Please look if you can see the image with FTP. If you can see it with ftp and download it, but the url is not working, then it is your server setting (something like "do not delivery images >kb" or so).
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

nflmerch

  • Jr. Member
  • **
  • Posts: 114
Re: Image upload - Large Image doesn't show
« Reply #8 on: January 26, 2012, 00:36:06 am »
I work on a local server and the image is in the folder when I upload it.  All the previous things I tried were on the same local server, including when I got it to work, so it's not my server settings.
the url where i get the 500 errors are:  images/stories/virtuemart/product/any_picture.jpg

Perhaps something is happening during migration, since I got a new install to work properly.  But I've tried migrating from VM1 to VM2   3 or 4 times, carefully following milbo's directions, and I get the same issue every time.


nflmerch

  • Jr. Member
  • **
  • Posts: 114
Re: Image upload - Large Image doesn't show
« Reply #9 on: January 27, 2012, 00:02:34 am »
Here's some strange behavior that might be a clue:

1.  Upload new product #1 and image
2.  Only thumb shows, Large image does not show in frontend, backend or with a direct URL.
3.  On my local server, I move the product image folder out of my web folder (to test the site without images)
4.  Uploading product #2 and image, still does not work.
5.  When I put the original image folder back in my web folder,  large image #1 works!

lipes

  • Full Member
  • ***
  • Posts: 720
Re: Image upload - Large Image doesn't show
« Reply #10 on: January 27, 2012, 01:11:11 am »
yep.. its true.. same problem here
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9853
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Image upload - Large Image doesn't show
« Reply #11 on: January 28, 2012, 02:41:24 am »
Hmm I do not understand the problem, locally I already upload wallpapers. Maybe you have spaces in the image names?
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

lipes

  • Full Member
  • ***
  • Posts: 720
Re: Image upload - Large Image doesn't show
« Reply #12 on: January 28, 2012, 02:56:24 am »
Milbo: hi, good night (from here).

I've got 1.7.3 (again) fresh and clen install with vm2

and also joomla 2.5 with vm2...

both of them cannot upload any the image file :(
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

lipes

  • Full Member
  • ***
  • Posts: 720
Re: Image upload - Large Image doesn't show
« Reply #13 on: January 28, 2012, 03:11:45 am »
ARGH...
now i FINALLY saw that VM2 in adding image files it's VERY stupid... that do users, like me, be stupid too...


In VM1.x we got a complete and wonderfull image upload .. it create 1 file thumbnail and 1 image file with normal size...
VM 1.x: Image Action   (X) None THIS IS THE DEFAULT
( ) ..  thumb
and when we select the file he automatically switches to AUTO CREATE THE THUMBNAIL!
IN VM 1.x: Just a simply click and it works!

In VM2.x we got the stupid "Upload File"...
with this options in "Image Action"  (X) None   THIS IS THE DEFAULT
 ( )  Upload
 ( )  Replace thumb

NO automatically switches!!!

If we click in save or save and exit the product NEVER upload ANY file.... because the Image action is default in NONE....

1 - We have to select / click in "UPLOAD"... to image upload... (this is so stupid)... of course we want to upload if we are in this place!!!!  Time wasting because this dont automatically switches :|

Please MILBO... do something like in VM1.x was wonderfull... why this?
bureaucracy, we are making life harder and difficult for all...

I already lost some days trying to see where was the real problem .. (if it was in Joomla versions... do some clean instalations... etc...)
Because of this crap (sorry) that I cannot upload any file ... I'm very stupid with this "have to select with the mouse" that option... ARGh !!
you need to change that please!! :(:(:(
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9853
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Image upload - Large Image doesn't show
« Reply #14 on: January 28, 2012, 13:32:43 pm »
Yeah, I said to you, you did not choose the option.

To let it switch automatically to upload is a good idea. We will add it, when there is some time for it. Please write it also to the other thread. It is really hard to read all the time, that it not works, when you know that it works. But nflmerch error is another one, because he knows that.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/