Author Topic: suhosin[878]: ALERT - configured request variable name length limit exceeded  (Read 5301 times)

MarcoDings

  • Beginner
  • *
  • Posts: 8
I am aware this is not really a bug as such. But apparently vm2 does not play nice with the default shosin installation

Jan 18 08:09:18 srv42 suhosin[878]: ALERT - configured request variable name length limit exceeded - dropped variable 'quantity%5B%5D=1&option=com_virtuemart&view=cart&virtuemart_product_id%5B%5D=3&virtuemart_manufacturer_id=2&virtuemart_category_id%5B%5D=939' (attacker '86.57.245.19', file '/home/micromem/srv/micromem.q-hive.com/www/index.php')

what would be the needed configuration ( what variables and what values) to have vm and suhosin "play nice"

tia Marco

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10000
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Hmm, wie use also suhosin, but not errors so far.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

MarcoDings

  • Beginner
  • *
  • Posts: 8
Hi,

Yet we see them ;)

Please share your suhosin settings ;)

dontflinch

  • Jr. Member
  • **
  • Posts: 152
we also use suhosin.  you need to google the suhosin setting and edit your appropriate php.ini file to a larger value.


from the error you mentioned it is probably one or more of these:

suhosin.request.max_array_depth
suhosin.request.max_array_index_length
suhosin.request.max_totalname_length
suhosin.request.max_value_length
*suhosin.request.max_varname_length
suhosin.request.max_vars