Author Topic: add to cart issues  (Read 10344 times)

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27903
  • Always on vacation
    • Jenkin Hill Internet
Re: add to cart issues
« Reply #15 on: January 09, 2012, 23:14:07 pm »
Your site works just fine on the Beez template.... apart from the bad display.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.5 10338 on Joomla 3.9.22 PHP 7.4.9

johnnyboy_31

  • Beginner
  • *
  • Posts: 14
Re: add to cart issues
« Reply #16 on: January 10, 2012, 20:50:11 pm »
Hi,

I use IE8 and it doesn't work or am I blind, or is it just my laptop with IE8? I also tested on a different laptop with IE9, also doesn't work

Please advise in how to debug.

Thanks!!!!

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10422
  • VirtueMart Version: 3+
Re: add to cart issues
« Reply #17 on: January 10, 2012, 21:09:32 pm »
the image carousel causes problems

^^^
YOUR image carousel has problems.

add to cart works for me in IE EXCEPT the ajax part does not work. I have to refresh page.



also, dont use google external js
 <script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js"></script>
  <script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jqueryui/1.8.16/jquery-ui.min.js"></script>

J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

notanothernumber

  • Jr. Member
  • **
  • Posts: 56
Re: add to cart issues
« Reply #18 on: January 17, 2012, 02:01:30 am »
I'm having massive dramas with this as well (see website www.costumeglitz.com.au) where if I switch off the 'Using the Virtuemart jQuery' the cart functionality works but adds nothing into the cart!? Any ideas out there?

notanothernumber

  • Jr. Member
  • **
  • Posts: 56
Re: add to cart issues
« Reply #19 on: January 17, 2012, 02:25:03 am »
Thank fek got this to work! Go into configuration.php file and change the entry:

public $dbtype = 'mysqli'
TO
public $dbtype = 'mysql'

Would be good to know why this worked though, any explanations out there?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: add to cart issues
« Reply #20 on: January 17, 2012, 02:27:08 am »
yes, dont use mysqli with j1.7 or better said php5.3 and j1.7, because php5.3 is using with mysql already mysqli by default... or other way round,. .mysql does not exist anylonger...

yehh confusing, but that is the reason behind it.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

edwardcox

  • Beginner
  • *
  • Posts: 7
Re: add to cart issues
« Reply #21 on: July 30, 2012, 05:29:01 am »
Hi All,
as a VirtueMart 2 newb I just wanted to say thank you to everyone who contributes to these threads.

My problem 'was' the same as everyone here, Joomla! 2.5.6 VM 2.0.8, and Add To Cart was playing up, no Popup modal, etc.

Simple search through this forum taught me to look at the HTML code and see what versions of JavaScript and JQuery were being loaded.
My conflict was BT Login module, and when I set it to 'Auto' determine load it resolved all my problems.

Kind Regards,

Edward.