Author Topic: joomla 2.5 beta and Vm2 can not install  (Read 4115 times)

citroen1968

  • Beginner
  • *
  • Posts: 2
joomla 2.5 beta and Vm2 can not install
« on: December 25, 2011, 12:41:10 pm »
Virtuemart and joomla 2.5 beta  use xampp 1.7.7 php 5.3.8

can not install VM2  into joomla2.5

got these message JModel: :getName() : can not get the  classname or parsen.



liv

  • Beginner
  • *
  • Posts: 15
Re: joomla 2.5 beta and Vm2 can not install
« Reply #1 on: December 25, 2011, 15:10:44 pm »
May be that is why I have this problem after upgrading from Joomla 1.73 to Joomla 2.5Beta1:
I have Virtuemart 2.0 and Joomla 2.5beta1. I get this errors:
Table class vendorTableVendor_medias not found in file.
Table class mediaTableMedias not found in file.
Table class categoryTableCategories not found in file.
Table class productTableProducts not found in file.
Table class userTableVmusers not found in file.

AmStaF

  • Beginner
  • *
  • Posts: 47
Re: joomla 2.5 beta and Vm2 can not install
« Reply #2 on: December 25, 2011, 21:50:25 pm »
J2.5 beta uses the latest joomla platform and also has new core features. VM is for j1.5/1.7. Don't try to crossbreed them.

Let vm-dev team polish vm2.0 and leave j2.5 for future (till Jan-10 for example :))

gwsdesk

  • Beginner
  • *
  • Posts: 2
Re: joomla 2.5 beta and Vm2 can not install
« Reply #3 on: December 26, 2011, 08:17:16 am »
J2.5 beta uses the latest joomla platform and also has new core features. VM is for j1.5/1.7. Don't try to crossbreed them.
This is a complete wrong statement. This is a VM installer error. VM 2.0 should run flaweless normally on Joomla 2.5. Beta1. Get the same errors and these are non Joomla related

Leo
(aka leolam with 10,400 support assists on Joomla forum)
MD GWS-Desk.com

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3973
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: joomla 2.5 beta and Vm2 can not install
« Reply #4 on: December 26, 2011, 10:02:40 am »
Hi,
Joomla 2.5 is not supported for now.
Plz wait ...

AmStaF

  • Beginner
  • *
  • Posts: 47
Re: joomla 2.5 beta and Vm2 can not install
« Reply #5 on: December 26, 2011, 13:04:32 pm »
This is a VM installer error. VM 2.0 should run flaweless normally on Joomla 2.5. Beta1. Get the same errors and these are non Joomla related

Yes, but no :)

VM2.0 installer is for j1.7.

For example, look at "libraries\joomla\application\component\model.php":

for j1.7 - public function getTable($name = '', $prefix = 'Table', $options = array())
for j2.5 - public function getTable($name = '', $prefix = '', $options = array())

This way in 2.5, when install script calls "$langTable = $this->getTable($table)", it raises error ( trying to get class name in function getName() ).

Add argument in administrator\components\com_virtuemart\helpers\tableupdater.php (public_function_createLanguageTables and private_function_portLanguageFields):

$langTable = $this->getTable($table, 'Table')
instead of
$langTable = $this->getTable($table)

and you will get successful installation (with some other bugs, yes :)).

Nevertheless, of course VM will not work anyway: there is no admin menu etc.

P.S. By the way, a strange string was found in script.virtuemart.php:
$updater->portOldLanguageToNewTables((array)$lang)