Author Topic: Getting multi-vendor to work...  (Read 1639 times)

cmatte

  • Beginner
  • *
  • Posts: 40
Getting multi-vendor to work...
« on: December 24, 2011, 16:10:52 pm »
Hi, I'd like to get multivendor working with vm 2. Mine is a very particular multivendor, the "common" one should perhaps be faster to configure.
I've enabled the option and put in various manufacturers.
Then I tried adding a personalized vendor into mysql table and now it appears. I understand I can, this way, create vendor-specific checkouts / shipments modules. For example, shipment is ok with the same plugin and different values set, so I've just configured it. Instead I would like to have a second paypal checkout that works differently. Say I want clients to pay for a commission, the same I want from my third part vendors, then I just forward orders to vendors, they do the rest making clients pay by cash on delivery, so I already had my commission as decided and they can manage and directly have their money, that seems the more efficient way to me right now.
I have done a double copy of the included plugin, and I am modifying its acting to accomplish my needs, correct me if this isn't the right way to modify the second plugin to avoid conflicts with the first one, I've created a new folder, called the .php and .xml with a 3rd at the end. This plugin will manage all the third parts sells. I will modify it later.
I see I can link specific products to specific manufacturers, and manufacturers can be linked to vendors, seems perfect!
The bad part happens when one goes to the cart.
It does not apply any of the rules set. It even forgets about setting any shopping price / payment method if something that isn't the first vendor is used. That's weird. I would want something like summing up prices for all the vendors in different "orders". I've navigated in the code and I see many undone parts that don't loose time working with the virtuemart_vendor_id. So that's not done at all, neither in the administrative part?
Has Vm 1. multi-vendor working, instead?
Thanks