Author Topic: [solved] Ice Tabs Don't Work When V2 Is Set Up  (Read 2641 times)

mygbn

  • Beginner
  • *
  • Posts: 19
[solved] Ice Tabs Don't Work When V2 Is Set Up
« on: December 18, 2011, 22:30:28 pm »
I have V2 Set up on joomla 1.7 but when i placed icetabs in to modules and went in to it up this message displays at the bottom:

Warning: require_once(/home/storemyg/public_html/components/com_virtuemart/virtuemart_parser.php) [function.require-once]: failed to open stream: No such file or directory in /public_html/modules/mod_icetabs/libs/elements/vmcategory.php on line 34

Fatal error: require_once() [function.require]: Failed opening required '/home/storemyg/public_html/components/com_virtuemart/virtuemart_parser.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /public_html/modules/mod_icetabs/libs/elements/vmcategory.php on line 34

any reason why i'm not very good when it comes to coding but i went to line 34:

This is it between lines 25 and 40

   if(!is_dir(JPATH_ADMINISTRATOR.'/components/com_virtuemart')) return JText::_('Virtuemart is not installed');
      // Load the virtuemart main parse code
      if(file_exists(JPATH_ADMINISTRATOR.'/components/com_virtuemart/virtuemart_parser.php'))
      {
         require_once(JPATH_ADMINISTRATOR.'/components/com_virtuemart/virtuemart_parser.php');
         $mosConfig_absolute_path = realpath(dirname(__FILE__).'/../..');
      }
      else
      {
         require_once(JPATH_SITE.'/components/com_virtuemart/virtuemart_parser.php');                 ( THIS IS LINE 34)
      }
      if(!is_array($this->value)) { $this->value = array(''. $this->value.'' => '1'); }
      else
      {
         foreach( $this->value as $_k => $tmpV)
         {

Please help this is a good module but i only want to use it with banners and not with Virtuemart.

Allso How Do Plugins Work With V2 as i want to use Tabs In The Product Page Of My Site


Thank You

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27570
  • Always on vacation
    • Jenkin Hill Internet
Re: Ice Tabs Don't Work When V2 Is Set Up
« Reply #1 on: December 18, 2011, 23:53:59 pm »
Icetabs is for VirtueMart 1.1 not VirtueMart 2. You will have to get in touch with Ice Theme about updating.

Plugin information is in the Wiki.  http://dev.virtuemart.net/projects/virtuemart/wiki/Plugin_system
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.6.8.10197 on Joomla 3.9.13 PHP 7.0.33

mygbn

  • Beginner
  • *
  • Posts: 19
Re: Ice Tabs Don't Work When V2 Is Set Up
« Reply #2 on: December 19, 2011, 00:24:17 am »
Thanks Problem Solved Now

xhgjzll

  • Beginner
  • *
  • Posts: 2
Re: [solved] Ice Tabs Don't Work When V2 Is Set Up
« Reply #3 on: February 07, 2012, 14:15:10 pm »
How to solved?