Author Topic: [solved] Standard payment errors.  (Read 7530 times)

kpg

  • Beginner
  • *
  • Posts: 32
    • konzeptplus
[solved] Standard payment errors.
« on: December 12, 2011, 19:05:57 pm »
Hi,

i use the RC3 J Version. And the standard payment is not showing in the frontend at all. Could it be, because i made the upgrade from Version RC2 M ?

@ alatak thanks for the percentage calc. on the paymentmethode.  ;D

And if the standardpayment and the value of the COM_VIRTUEMART_SHIPMENT are going to work, it will be even more awesome. 

regards

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10338
  • VirtueMart Version: 3+
Re: Standard payment errors.
« Reply #1 on: December 12, 2011, 19:10:42 pm »
have you looked in payment methods? and is it published?
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

kpg

  • Beginner
  • *
  • Posts: 32
    • konzeptplus
Re: Standard payment errors.
« Reply #2 on: December 12, 2011, 19:28:20 pm »
Yes, they are both published. I disabled the (Enable Automatic Selected Payment? ) to look, if it makes a difference. Unfortunately, not.

and i tested it on two pages. On a Joomla 1.6.x and a J 1.7.x

any more ideas?

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10338
  • VirtueMart Version: 3+
Re: Standard payment errors.
« Reply #3 on: December 12, 2011, 19:41:52 pm »
confirmed, with mine too

J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

kpg

  • Beginner
  • *
  • Posts: 32
    • konzeptplus
Re: Standard payment errors.
« Reply #4 on: December 12, 2011, 19:51:11 pm »
So. I'm not the only one.

And do you have the issue with the Shipment Method too? that it shows no fee?


PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10338
  • VirtueMart Version: 3+
Re: Standard payment errors.
« Reply #5 on: December 12, 2011, 20:11:32 pm »
kpg,

I should have known the answer to this because it did it the other day.

YOU have to login, or fill in the address stuff first for it to show up
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

kpg

  • Beginner
  • *
  • Posts: 32
    • konzeptplus
Re: Standard payment errors.
« Reply #6 on: December 12, 2011, 20:18:26 pm »
 :D

Thanks for the answer. I will test it ASAP. It seems, that i have now a Database Error.  :(

regards

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9853
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Standard payment errors.
« Reply #7 on: December 12, 2011, 20:48:59 pm »
Yeah, the problem is that the shipment itself can depend by the address.

The normal checkout process lets you fill the address first, and let you then select the shipment.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

kpg

  • Beginner
  • *
  • Posts: 32
    • konzeptplus
Re: Standard payment errors.
« Reply #8 on: December 12, 2011, 21:09:46 pm »
@Milbo, thanks for the reply. But it seems, that i still do something wrong. Each time i set up the parameters like country (switzerland) and Package Fee, it deletes it after the save. So what do i have to do?

It seems that this issue is discussed on a other topic.

I have tried to setup shipping - VM Shipment on my install but when i fill in all the details I save the page and it returns blank again with all the settings lost. If I choose the VM Shipper instead I can fill out the details but going through the checkout none of the values for the shipping costs are applied. No error messages are thrown up during the process on the backend but frontend during checkout I get:

Code: [Select]
Notice: Undefined property: TablePaymentmethods::$cost in /var/www/vhosts/coralsaquaticsmailorder.com/httpdocs/plugins/vmpayment/standard/standard.php on line 111

But i couldn't find a proper fix jet.

@BanquetTables.pro Thx for the hint. It works. But i'm not sure if that is the perfekt way.

regards


alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2047
    • alatak.net
Re: Standard payment errors.
« Reply #9 on: December 13, 2011, 10:22:23 am »
Hi,

Quote
@Milbo, thanks for the reply. But it seems, that i still do something wrong. Each time i set up the parameters like country (switzerland) and Package Fee, it deletes it after the save. So what do i have to do?
It was a bug :)
This bug is solved in the K version.
PLease update.

kpg

  • Beginner
  • *
  • Posts: 32
    • konzeptplus
Re: Standard payment errors.
« Reply #10 on: December 13, 2011, 12:32:02 pm »
Hi alatak,

I updated to the k Verison. But the Problem with the shipment is still there. It does not save any changes and does not ad the fee in the frontend.
I used the VM-shipment and not the VM-shipper. Wich i belive is a olde bone from a erlier version. Or do i missunderstanding something?

thanks for the reply.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9853
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Standard payment errors.
« Reply #11 on: December 13, 2011, 13:00:03 pm »
Maybe you must delete the table of the shipment plugin, or adjust it to the new format.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

kpg

  • Beginner
  • *
  • Posts: 32
    • konzeptplus
Re: Standard payment errors.
« Reply #12 on: December 13, 2011, 13:39:57 pm »
This was my first thought too. I don't want to delete it at the "trial and error" method. So if would know how the tables has to be, that would be perfekt.

thx for a helpful answer

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9853
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Standard payment errors.
« Reply #13 on: December 13, 2011, 14:20:47 pm »
Here read this http://forum.virtuemart.net/index.php?topic=94914.msg311392#msg311392
"Please note that I needed to delete the existing Shipment Method and create it again, presumably required to create the missing SQL file."
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

kpg

  • Beginner
  • *
  • Posts: 32
    • konzeptplus
Re: Standard payment errors.
« Reply #14 on: December 13, 2011, 15:24:44 pm »
Hi,

I deleted all the made shipmentmethod i made. And i also updated the aio. But after i made a new shipmentmode it seems that it still got the same issue. I guess that i should delet some tables.

Hi,

Quote
Please note that I needed to delete the existing Shipment Method and create it again, presumably required to create the missing SQL file.
Yes you are completly rigth. The shipment and payment tables have changed. So they must be recreated.

And can i delet the Plugin (VM - Shipper, By weight, ZIP and countries). This is the old one. right?
Plus, the language strings of the shipmentmethode is not complete in German. (just a hint) ;-)