Author Topic: [FIXED] VM2 doesn't applies custom views  (Read 2680 times)

Razva

  • Jr. Member
  • **
  • Posts: 55
[FIXED] VM2 doesn't applies custom views
« on: September 30, 2011, 18:14:11 pm »
Hi,

1) Please look at the "vm1.jpg" image attached. As you can see we've entered a "1" number after the short description. Also please note that the short description is inserted into a totally different part of the view compared to the default view;
2) Please look at the "vm2.jpg" and "vm3.jpg" images attached. As you can see we've set VM to use our custom view (oven) in both general settings and each category;
3) Now please take a look at http://www.semineemures.ro/produse/finisaje/finisaje-clasice/canaria-detail . It's the good ol' default view...

So as you can see VM ignores the settings we've made in the general settings and each category, and keeps using the default view.

Is there any problem on our side, or is this a bug?

Thanks!

[attachment cleanup by admin]

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9969
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: VM2 doesn't applies custom views
« Reply #1 on: September 30, 2011, 18:59:29 pm »
I have an idea, maybe the default is set as override in the categories, please take a look on your categories. I think I just must remove that the default gets stored.

I assume you made your categories, all set on default.php and changed then the default to oven.php, but it is still stored an override in the category. Of course this is not a desired behaviour, lets take a look on it.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Razva

  • Jr. Member
  • **
  • Posts: 55
Re: VM2 doesn't applies custom views
« Reply #2 on: September 30, 2011, 19:11:46 pm »
Quote
I assume you made your categories, all set on default.php and changed then the default to oven.php, but it is still stored an override in the category. Of course this is not a desired behaviour, lets take a look on it.
Yup, you've read my...mouse... :P We've created the categories by using the default, than changed the default to oven.

Quote
I have an idea, maybe the default is set as override in the categories, please take a look on your categories. I think I just must remove that the default gets stored.
Nope, oven.php is set in all the main categories and all subcategories. We've even set oven as the default...with no result :(

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9969
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: VM2 doesn't applies custom views
« Reply #3 on: September 30, 2011, 20:10:26 pm »
Hmmm many times demonstrated last month, I wonder. Maybe I can understand better with a backend access to your page.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Razva

  • Jr. Member
  • **
  • Posts: 55
Re: VM2 doesn't applies custom views
« Reply #4 on: September 30, 2011, 21:16:09 pm »
I've PM-ed you the user/pass. If you can take a look...it would be GREAT! :D

Later edit: the problem is fixed in the latest SVN.

jpreskitt

  • Beginner
  • *
  • Posts: 40
Re: [FIXED] VM2 doesn't applies custom views
« Reply #5 on: December 01, 2011, 00:51:41 am »
Razva, did Milbo ever help you with this? i cannot seem to get my VM cat to display with the edited overrides i've created.
thanks in advance,
john

Razva

  • Jr. Member
  • **
  • Posts: 55
Re: [FIXED] VM2 doesn't applies custom views
« Reply #6 on: December 01, 2011, 03:48:59 am »
Razva, did Milbo ever help you with this? i cannot seem to get my VM cat to display with the edited overrides i've created.
thanks in advance,
john
Yeah, the latest SVN fixed the bug at that time...but it may be a new bug on the same matter...?

jpreskitt

  • Beginner
  • *
  • Posts: 40
Re: [FIXED] VM2 doesn't applies custom views
« Reply #7 on: December 01, 2011, 05:52:37 am »

Yeah, the latest SVN fixed the bug at that time...but it may be a new bug on the same matter...?
[/quote]

Actually, the problem was I was renaming my default.php files to something else. Changing them back fixed it and now i can override the VM layouts. Weird though, i though it would support renaming.
John