Author Topic: WYSIWYG editor will not save changes to product details on iMac SOLVED  (Read 1751 times)

davidacton

  • Beginner
  • *
  • Posts: 4
We are developing a site to test each RC as it is released. 
Each release since RCJ (when we began testing) has exhibited the same problem when the admin system is accessed on our iMac.  Changes to the product details page in the WYSIWYG editor will not save and the text returns to an unformatted string. 

This behaviour is not reproduced on our PCs.
The problem does NOT occur on normal content pages, only VM product details.
The problem occurs with sites on our test web server and local development server.

We have tested with Firefox, Chrome and Safari and using JCE, Joomla FCK and Tiny MCE, in each case the same issue is experienced.

This issue does not occur in any version of VM1.

iMac details are OSX 10.6.8 - latest versions of each browser  We only have one Mac for testing purposes so I cannot comment on other versions.

Joomla 1.7.2


Database Version    5.0.92-community
Database Collation    utf8_general_ci
PHP Version    5.2.13
Web Server    Apache
WebServer to PHP Interface    cgi
Joomla! Version    Joomla! 1.7.2 Stable [ Ember ] 17-Oct-2011 14:00 GMT
Joomla! Platform Version    Joomla Platform 11.2.0 Stable+Modified [ Omar ] 27-Jul-2011 00:00 GMT
User Agent    Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.120 Safari/535.2

Cleanshooter

  • Contributing Developer
  • Jr. Member
  • *
  • Posts: 69
    • My Blog
Re: WYSIWYG editor will not save changes to product details on iMac
« Reply #1 on: November 18, 2011, 17:33:58 pm »
Thats odd... I develop on a MAC (OSX 10.6.8) at work in VM and have had no such issue through the RC and I have been developing since H.

Try using codeMirror editor and see if it strips the tags after clicking SAVE.... I'm not sure why it would only be on the VM product details page.

I know that TinyMCE will prohibit these elements by defualt: script,applet,iframe.  Which you can change in the TinyMCE plugin settings...

I would think that the issue lies with in your MAC or it's settings.  Since no one else has experience this issue.

Now that I think about it I did notice once that it would strip some scripts if I copied and pasted in JCE and since JCE extends TinyMCE... I had an onclick script that kept getting stripped from my links...  I just thought it was the editor.  But when I copied and pasted in CodeMirror it worked fine...  But if I applied formatting in JCE it stuck just fine.
- Cleanshooter

davidacton

  • Beginner
  • *
  • Posts: 4
Re: WYSIWYG editor will not save changes to product details on iMac
« Reply #2 on: November 22, 2011, 12:39:29 pm »
Hi.  Thank you for your response.  CodeMirror does strip out tags on save interestingly.  We just tested on an iPad and found the same issue.  I am going to borrow another Mac tonight to see if I can reporduce the problem on it, I will post my results tomorrow.

Cheers  David

davidacton

  • Beginner
  • *
  • Posts: 4
Re: WYSIWYG editor will not save changes to product details on iMac
« Reply #3 on: November 22, 2011, 17:45:08 pm »
Cracked it.  When I created the addiitonal Super User login in Joomla, VM did not assign the new user to the admin group, which caused the problem.

Once the new user was manually assigned to the admin group, the issue disappeared.

Cheers  David