Author Topic: Warning: Attempt to assign property of non-object  (Read 7487 times)

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10321
  • VirtueMart Version: 3+
Re: Warning: Attempt to assign property of non-object
« Reply #15 on: November 14, 2011, 19:35:02 pm »
yes,

J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

mercomarine

  • Jr. Member
  • **
  • Posts: 129
    • Merco Marine
Re: Warning: Attempt to assign property of non-object
« Reply #16 on: November 14, 2011, 20:25:08 pm »
Not sure if your last response went thru. completely All i got was "Yes,"
Joomla Version 1.5.23
VirtueMart 1.1.9 stable
Apache: 1.3.42
MySQL 5.0.91
PHP: 5.2.5
phpMyAdmin 3.3.10.2

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10321
  • VirtueMart Version: 3+
Re: Warning: Attempt to assign property of non-object
« Reply #17 on: November 14, 2011, 20:37:51 pm »
could this have something to do with the problem I'm having editing products?

yes
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

TooNewbie

  • Beginner
  • *
  • Posts: 20
Re: Warning: Attempt to assign property of non-object
« Reply #18 on: May 19, 2012, 09:02:39 am »
I was trying to disable an editor I was trying to use the other day. Not sure if that caused my problem, but ever since then I get an error message that says "Warning: Attempt to assign property of non-object in /home/mysite/public_html/libraries/joomla/html/editor.php on line 309" And I am not able to make edits to at least two fields of my products (name or description)

I have since re-enabled "Editor - TinyMCE" under plugins and also checked to make sure it is set as the default Default WYSIWYG Editor under global config. Still not working.

This is a live site. >>>>>Major problem here as I will need to edit about 600 products here in about a month. <<<<<

I have looked for an answer in the forum, but every time i see something related to my problem, its 4 people saying they have the problem, and no one answering with a solution.

Im using Joomla Version 1.5.23
VirtueMart 1.1.9 stable 
Apache:
1.3.42
Curl:
7.15.5
MySQL
5.0.91
PostgreSQL
8.4.7
Python:
2.4.3
ImageMagic:
6.4.3
Program
Version
Perl:
5.8.8
PHP:
5.2.5
ionCube Loader:
3.1.31
Zend Optimizer:
3.3.3
phpMyAdmin
3.3.10.2
OpenSSL:
0.9.8e-fips-rhel5

The solution is this:

http://forum.virtuemart.net/index.php?topic=93039.0


enable *No editor and *TinyMCE and it´s done



Please post as solved for future references.