Author Topic: [SOLVED]2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174  (Read 5677 times)

martin-nord

  • Beginner
  • *
  • Posts: 26
Hi,

I did a fresh installation of Joomla 1.7 and VM2. I did all necessary configuration. I also updated to the lastest VM version (using "com_virtuemart.1.9.8H") and installed "de-DE_VirtueMart2-lang_v1.9.8G.zip".

I tried to place a test order, as soon as a I click on "Basket" (Warenkorb) i get the following error messages (reproducable):

http://www.mydomain.com/index.php/component/virtuemart/cart
Quote
Fatal error: Class plgVmPaymentStandard contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (vmPaymentPlugin::plgVmOnConfirmedOrderGetPaymentForm) in [...path-to-JOOMLA...]/plugins/vmpayment/standard/standard.php on line 174

VM: 2.0.0-RC-2H
Joomla!-Version: Joomla! 1.7.1 Stable [ Ember ] 26-Sep-2011 14:00 GMT
PHP-Version: 5.2.17
Webserver: Apache

hrm... hope it's not my fault... hope I could help reporting a bug,
Martin.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9918
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: 2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #1 on: October 10, 2011, 17:44:55 pm »
Thanks, we are on it
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9918
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: 2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #2 on: October 11, 2011, 12:57:38 pm »
Update, I think you didnt updated the extensions with the aio. Please do that and report if it helped, thanks.

Next update, maybe it is conntected to this http://forum.virtuemart.net/index.php?topic=91627.msg301030#msg301030
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Rittermann

  • Beginner
  • *
  • Posts: 11
Re: 2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #3 on: October 11, 2011, 22:43:27 pm »
I am having the exact same problem..  ???

Maibritt

rlspencer

  • Beginner
  • *
  • Posts: 18
Re: 2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #4 on: October 13, 2011, 06:19:55 am »
Hi Milbo,

AIO, does that mean All-In-One.. The reason I ask in I tried to update the from 2.0.0-RC-2G to RC-2H using the remote installer and it failed so I did it manually. I used the extension manager in J1.7 and it said i was successful.  Now I am getting the same thing..

Fatal error: Class plgVmPaymentStandard contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (vmPaymentPlugin::plgVmOnConfirmedOrderGetPaymentForm) in /homepages/9/d345476470/htdocs/Herbaceousacres/plugins/vmpayment/standard/standard.php on line 174..

I am up late so if need me to try something please let me know.  My customer loves the look of your cart and the interface but like to have it up and running...lol. 

Thank you for all the work you do and for taking the time to respond to the community.

Rick S.

mirefoot

  • Beginner
  • *
  • Posts: 6
Re: 2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #5 on: October 13, 2011, 10:36:59 am »
If you update the plugins with the new all in one it works fine

Rittermann

  • Beginner
  • *
  • Posts: 11
Re: 2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #6 on: October 13, 2011, 15:45:17 pm »
How do I use the new AIO?

When I chose AIO I get the following message:

Just uninstall this componen. It is just for installation of the modules and plugins for VirtueMart 2
Your modules and plugins are left untouched. You have to uninstall them manually.

 :-\

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9918
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: 2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #7 on: October 13, 2011, 15:49:04 pm »
This means that you have the old aio installed, download the latest aio provided within this package: http://dev.virtuemart.net/attachments/download/324/virtuemart1.9.8.RC2H_extract_first.zip

Just install it over the old one, it is an updater.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Rittermann

  • Beginner
  • *
  • Posts: 11
Re: 2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #8 on: October 13, 2011, 16:09:13 pm »
Thanks  ;D

rasalghul

  • Beginner
  • *
  • Posts: 43
I'm getting this error

Fatal error: Class plgVmPaymentStandard contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (vmPaymentPlugin::plgVmOnConfirmedOrderGetPaymentForm) in /home/a5504495/public_html/plugins/vmpayment/standard/standard.php on line 174

Virtuemart:com_virtuemart.1.9.8J I installes manually... 'cause updater didn't work.


rasalghul

  • Beginner
  • *
  • Posts: 43
Re: [SOLVED]2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #10 on: October 25, 2011, 07:24:28 am »
Is there an AIO for this version.. com_virtuemart.1.9.8 ???

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2047
    • alatak.net
Re: [SOLVED]2.0.0-RC-2H: Class plgVmPaymentStandard / standard.php on line 174
« Reply #11 on: October 25, 2011, 08:48:24 am »
Hi,

Yes, there is always AIO.
Download the J version:
http://dev.virtuemart.net/projects/virtuemart/files

unzip, and then install the aoi component. That will update all the files. Some database tables have change, so go
VirtueMart > Tools > tools & Migration, and click on "Install tables or if necessary update them " button.