Author Topic: 2.0.0-RC-2i: Error when activating Shopping Card Module  (Read 3469 times)

martin-nord

  • Beginner
  • *
  • Posts: 26
2.0.0-RC-2i: Error when activating Shopping Card Module
« on: October 15, 2011, 13:00:03 pm »
As soon as I activate the VM Shopping Card Module, I get this

Quote
Warning: Cannot use a scalar value as an array in /homepages/[path to Joomla]/plugins/vmshipper/weight_countries/weight_countries.php on line 404

Catchable fatal error: Argument 2 passed to plgVmShipperWeight_countries::plgVmOnShipperSelectedCalculatePrice() must be an instance of TableShippingCarriers, array given in /homepages/[path to Joomla]/plugins/vmshipper/weight_countries/weight_countries.php on line 187


VM: 2.0.0-RC-2i
J!: 1.7.1
Template: JSN Tendo Pro

martin-nord

  • Beginner
  • *
  • Posts: 26
Re: 2.0.0-RC-2i: Error when activating Shopping Card Module
« Reply #1 on: October 15, 2011, 14:04:00 pm »
Ok, I found this thread...

http://forum.virtuemart.net/index.php?topic=91898.0
Max wrote:
Quote
Heyhoo Jörg, we dont have this problem using j1.5,
But this is not a j1.7 error, I am quite sure, that you forgot to move the files into the subdirectories.... hmm maybe I provide a windows shell doing that (hey linux geeks, of course lets also add a command file for linux).

In my case it's a fresh 1.7 Joomla, thus fresh VM2 installation.

Martin.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10040
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: 2.0.0-RC-2i: Error when activating Shopping Card Module
« Reply #2 on: October 15, 2011, 15:46:34 pm »
You dont need to copy the files, only people who use the svn must do that, but you must also use the aio installer to update your plugins.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

martin-nord

  • Beginner
  • *
  • Posts: 26

martin-nord

  • Beginner
  • *
  • Posts: 26
Solved: Re: 2.0.0-RC-2i: Error when activating Shopping Card Module
« Reply #4 on: October 15, 2011, 17:48:33 pm »
I don't know why, I just installed AIO again (drübergebügelt). Now it works.

thanks a lot.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10040
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: 2.0.0-RC-2i: Error when activating Shopping Card Module
« Reply #5 on: October 15, 2011, 18:53:05 pm »
Btw, great avatar image, Martin.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

martin-nord

  • Beginner
  • *
  • Posts: 26
Re: 2.0.0-RC-2i: Error when activating Shopping Card Module
« Reply #6 on: October 15, 2011, 20:31:25 pm »
I called it "with VM daddys" ;-)