Author Topic: Bots are not using the correct URL  (Read 1912 times)

gkt

  • Beginner
  • *
  • Posts: 11
Bots are not using the correct URL
« on: October 07, 2011, 11:01:00 am »
It looks like that bots (Googlebot, Baiduspider) etc. are creating new URL's and are not using the correct URLin JoomSEF / VM.

It looks like the bots are creating a new URL like this (Category A/Product) ie
wool/uhu-extra-all-purpose-gel-glue-for-vertical-surfaces-and-crafts-in-tube-20ml-ref-40253

instead of the correct URL (Category b/Category ba/Category baa/Product) ie
adhesives-tapes/adhesives/all-purpose/uhu-extra-all-purpose-gel-glue-for-vertical-surfaces-and-crafts-in-tube-20ml-ref-40253

I have already disabled the "cookie check" in VM and it made no difference.

I am running
JoomSEF 3.8.2
VirtueMart Extension 2.0.35
Joomla 1.5.23
VirtueMart 1.1.9

Thank you
Glenn

I don't know if this is anything to do with it I am also have problems with breadcrumbs, changing.

It goes from
Printer-Fax-Copier Supplies\
to
Wool \ Printer-Fax-Copier Supplies \ Correctable Ribbons  etc
or
Wool\wool

It looks like the category "wool" is being used like the default shop name and is in front of everything.  How can I change this?
 

Simon77

  • Beginner
  • *
  • Posts: 12
Re: Bots are not using the correct URL
« Reply #1 on: April 26, 2012, 10:59:07 am »
Hi

Did you ever sort this.  I seem to be having a similar problem

Thanks

Simon

Pirata

  • Beginner
  • *
  • Posts: 1
    • vestidos de moda
Re: Bots are not using the correct URL
« Reply #2 on: May 10, 2012, 09:50:58 am »
Hi, I have exactly the same problem and its very frustrating. One of the catchs of my website is the design and I see that a lot of time the page that is indexed has no design at all and looks horrible.

Let me show you an example:

Page indexed:
http://www.limonbay.com/index2.php?page=shop.product_details&product_id=128&flypage=flypage.tpl&pop=1&option=com_virtuemart&Itemid=2

Real page:
http://www.limonbay.com/index.php?page=shop.product_details&product_id=128&flypage=flypage.tpl&pop=1&option=com_virtuemart&Itemid=2

As you can see, the only difference between these two are in /index.php and /index2.php

I wonder how and why does this index2 creates by itself...  ???

Any idea about how to solve it? Thanks!