Author Topic: [improved] Info: Attention dangerous database still active due config setting...  (Read 4406 times)

nflmerch

  • Jr. Member
  • **
  • Posts: 114
Attempting to update from subrelease G to subrelease H  on j1.71 and the installer gives me this message:

"Info: Attention dangerous database still active due config setting in file"

 :o

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9853
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
This is correct. Just disable it, when you want to prevent actually use of the database tools (can delete all tables)
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

nflmerch

  • Jr. Member
  • **
  • Posts: 114
Oh I understand, it's the configuration setting "Enable database Update tools".  Thanks for explaining

Axiom

  • Beginner
  • *
  • Posts: 6
if it's a settings notification then have the message say THAT.

having a message tell me "the thermonuclear properties of a liquid neutrino gravity well potentially impregnates cows" is NOT the same as "permissions error moving file"

had I not googled this I would have had to go through all the database and config files to manually determine a box was checked.  :P

thank you for the clarification, but please update the 1.9.8H installer to save the other thousand people about to perform the same update from having heart failure.

nflmerch

  • Jr. Member
  • **
  • Posts: 114
I agree, the error should say something like "The configuration setting "Enable database Update tools" is enabled. Please disable for security measures."

The words "dangerous database" in the error did give me a good scare.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9853
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
hehe okey
update: improved version is in the svn
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/