Author Topic: Athorize.net pending to confirmed issues  (Read 4799 times)

jgayle64

  • Beginner
  • *
  • Posts: 2
Athorize.net pending to confirmed issues
« on: September 07, 2011, 03:45:11 am »
Using Joomla 1.5.23. and Authorize.net as my payment gateway. Everything is working EXCEPT the order status is not changing from "pending" to "confirmed" even though the transaction has processed and the funds have been transferred. I have the configuration set to confirmed in the payment method panel. Any ideas?

pipgraphics

  • Beginner
  • *
  • Posts: 10
Re: Athorize.net pending to confirmed issues
« Reply #1 on: October 19, 2011, 11:52:15 am »
I have the same problem but with paypal and sagepay, I cant believe no one have responded to this thread.

Did you find the answer?

Eric Brown

  • Jr. Member
  • **
  • Posts: 77
  • So long, and thanks for all the fish.
    • CBA Web Development
Re: Athorize.net pending to confirmed issues
« Reply #2 on: December 19, 2011, 20:52:49 pm »
It is because 1000's of others are having the same issue as am I.

All of a sudden...BAM!...Sticks ONLY on Pending after a successful transaction.

Man..things just do not work as smoothly as they used to.  A little irritating as I have been using Mambo/Joomla since 2005! I never had these issues until just this year!  Grrrr!
So long, and thanks for all the fish!

Eric Brown

  • Jr. Member
  • **
  • Posts: 77
  • So long, and thanks for all the fish.
    • CBA Web Development
Re: Athorize.net pending to confirmed issues
« Reply #3 on: December 19, 2011, 21:03:19 pm »
Okay..I believe I have this resolved.

Choose. "Use Payment Processor" in the Authnet Config

When using Authorize.net, you MUST NOW use your API Login Number.  This is the number that shows up AFTER YOU Login to Authorize.net, then select "Settings" Under Account.

THIS IS IT.  THIS SOLVES IT.  THIS IS THE ANSWER.  HOW DO I KNOW? Because I tested it for another client having the same issue!  If for some reason, this does not work for you, then you did something wrong and you need to check your settings!

Eric
So long, and thanks for all the fish!