Author Topic: User Registration/Checkout Redirect issue  (Read 41248 times)

netcomp

  • Beginner
  • *
  • Posts: 4
User Registration/Checkout Redirect issue
« on: August 24, 2011, 08:48:42 am »
Hi, I'm about to pull my hair out on this one...started having problems with my checkout redirecting to the front page...searched and searched and have put almmost 2 days into trying to figure it out.  Then I noticed that the user information from the checkout form isn't being inserted into the database...so I tried adding a user from the VM admin and got the error:

Error: Missing value for field "First Name".
Error: Missing value for field "Last Name".
Error: Missing value for field "Address 1".
Error: Missing value for field "City".
Error: Missing value for field "Zip/Postal Code".
Error: Missing value for field "State/Province/Region".
Error: Missing value for field "Phone".

Tried updating an existing successful VM user and they lost all of their info (assuming blanks were inserted into the table ala above).

I have tried just about every answer in every thread but I'm not getting anywhere...

1000 internet points and a whole bunch of good karma goes to anyone that can help me out or has a link to a thread that I have overlooked.

TIA

netcomp

  • Beginner
  • *
  • Posts: 4
Re: User Registration/Checkout Redirect issue
« Reply #1 on: August 24, 2011, 08:57:31 am »
just for the record url is http://netcompdirect.com/sb4

VirtueMart 1.1.9
Joomla! 1.5.23

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26095
  • Always on vacation
    • Jenkin Hill Internet
Re: User Registration/Checkout Redirect issue
« Reply #2 on: August 24, 2011, 22:52:15 pm »
Add to cart uses www.netcompdirect.com  - with www.

See the FAQ -  http://forum.virtuemart.net/index.php?topic=82238.0
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.3.9614 on Joomla 3.7.4 PHP 7.0.22

Testing VM3.2.3.9614 on J!3.7.4

netcomp

  • Beginner
  • *
  • Posts: 4
Re: User Registration/Checkout Redirect issue
« Reply #3 on: August 25, 2011, 01:05:35 am »
thanx I appreciate the reply...feel like I'm in my in my own little world. however, this isn't an "add to cart" issue and both http and https are using www now (I switched it a little earlier).  didn't do any good...

any other suggestions?  I am using K2Mart...if I was to reinstall VM what would be the impact?  (theres only about 30 products)

TIA

netcomp

  • Beginner
  • *
  • Posts: 4
Re: User Registration/Checkout Redirect issue
« Reply #4 on: August 25, 2011, 04:51:52 am »
I ahve uninstalled the virtuemart component and reinstalled it using the VM download component...its still redirecting to the front page.

Bravo

  • Beginner
  • *
  • Posts: 11
Re: User Registration/Checkout Redirect issue
« Reply #5 on: November 01, 2011, 20:49:40 pm »
Netcomp,
I am having a similar problem.
Did you ever find a solution?
Any advice would be greatly appreciated.

Sonjoshuaz

  • Beginner
  • *
  • Posts: 3
Re: User Registration/Checkout Redirect issue
« Reply #6 on: January 29, 2012, 07:50:06 am »
Hello everyone have the same issue.
When I get to the shipping Form and a required field is empty.
I get the same error if does cell are empty.
 
Error: Missing value for field "First Name".
Error: Missing value for field "Last Name".
Error: Missing value for field "Address 1".
Error: Missing value for field "City".
Error: Missing value for field "Zip/Postal Code".
Error: Missing value for field "State/Province/Region".
Error: Missing value for field "Phone".
How can I get the Validation to work to show the Missing fields.
Please Help me I am getting bold I am pulling my hair out.
Thanks So much .

jcalvert2

  • Beginner
  • *
  • Posts: 6
Re: User Registration/Checkout Redirect issue
« Reply #7 on: October 16, 2012, 05:30:40 am »

hculbert

  • Beginner
  • *
  • Posts: 1
Re: User Registration/Checkout Redirect issue
« Reply #8 on: January 21, 2014, 18:54:46 pm »
Solution found!
Hi everyone,
I've also had this problem for a couple of days now and it was doing my head in! This page comes up in the search rankings so I thought I'd post the solution where other people are most likely to find it.

This is the link to the solution, I did not come up with this myself so can't help with any other issues you have.

http://network.convergenceservices.in/forum/46-virtue-mart/3635-supress-vm-messages-missing-value-for-first-name.html

It worked perfectly for me and still allows other system messages so fulfills all the requirements I had.

I hope this helps!

Jonathan_Ht

  • Beginner
  • *
  • Posts: 1
Re: User Registration/Checkout Redirect issue
« Reply #9 on: August 07, 2014, 13:08:12 pm »