Author Topic: Ajax Cart module not showing while SSL  (Read 2747 times)

bruzzler

  • Beginner
  • *
  • Posts: 28
Ajax Cart module not showing while SSL
« on: May 14, 2011, 16:03:26 pm »
Hi guys,

hope you can help me, I have one very urgent problem with my MYNXX Rockettheme template. Before anyone redirects me to RT forum, I already asked there: http://www.rockettheme.com/forum/index.php?f=186&t=131742&rb_v=viewtopic, but they said, this could be a Virtuemart problem
Everything works fine, as long as I'm not on a SSL-secured site. When entering i.e. the Checkout, which is SSL, the Ajax cart module won't fade in any longer. Oddly the other slide modules (Login etc) show without any problems...
Does anyone have a clue?

Here some Info:

1. Yes, I'm using SH404SEF, but I tried to disable it completely -->no difference

2. My live site variable is not set in configuration php, empty

3. regular: http://www.stuffbeaters.de/
ssl: https://order.stuffbeaters.de/
and I use ony ssl when necessary, that means, account/checkout

4. Yes, I redirect from non to www. in htaccess:
RewriteCond %{HTTP_HOST} !^www.stuffbeaters.de$ [NC] [OR]
RewriteCond %{HTTP_HOST} !^order.stuffbeaters.de$ [NC]
RewriteRule ^(.*)$ http://www.stuffbeaters.de/$1 [R=301,L]

5. Use Ajax when Add to cart disabled

6. Firebug Error on Checkout page:
zur-be...ected=1 (Zeile 107)
POST https://order.stuffbeaters.de/index2.php
303 See other
627ms
jscss....s&gz=gz (Zeile 1)
Parameterapplication/x-www-form-urlencoded
only_page 1
option com_virtuemart
page shop.basket_short
Source
only_page=1&page=shop.basket_short&option=com_virtuemart

Hope anyone could help me with this, I'm quite lost here, thanks a lot!

Thanks and regards
André

//Edit: I tried to set the regular domain to order.stuffbeaters.de and the ssl to https://order.stuffbeaters.de and then it works.
Can't I use a subdomain for checkout=? or does anybody know a trick (by htaccess or sth else) so that it might work?

bruzzler

  • Beginner
  • *
  • Posts: 28
Re: Ajax Cart module not showing while SSL
« Reply #1 on: May 17, 2011, 10:13:58 am »
nobody???