Author Topic: Tutorial: How to get Facebook Like working on your Virtuemart site  (Read 107814 times)

galaxy

  • Beginner
  • *
  • Posts: 1
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #75 on: July 12, 2011, 23:39:39 pm »
Kevin, thank you very much for your help and instructions.

fokyip

  • Beginner
  • *
  • Posts: 2
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #76 on: July 27, 2011, 18:58:13 pm »
Hi Kevin, I'm trying to figure out why it's giving me a facebook error I have

System - VM Open Graph 1.9
System - VM Add Canonical 1.2
I went to virtue mart and unchecked Enable the Cookie Check?

I enabled and disable Canonical neither works

The link is
http://hb.lookmatters.net/bracelet-collection/detail/2-bracelet-collection/flypage/2-1aw11bb?sef=hcfp

I read for this forum and instructions I don't know what else to do?

Thank you in advance.

kevinwood

  • Jr. Member
  • **
  • Posts: 151
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #77 on: July 27, 2011, 20:02:05 pm »
Hi Kevin, I'm trying to figure out why it's giving me a facebook error I have

System - VM Open Graph 1.9
System - VM Add Canonical 1.2
I went to virtue mart and unchecked Enable the Cookie Check?

I enabled and disable Canonical neither works

The link is
http://hb.lookmatters.net/bracelet-collection/detail/2-bracelet-collection/flypage/2-1aw11bb?sef=hcfp

I read for this forum and instructions I don't know what else to do?

Thank you in advance.

When you go to the link you have posted and click Like it returns "error", as you noted.  What you may not have realized is that the word "error" is actually a link that provides some further information.  In this case, it says:

The app ID "153750941361536" specified within the "fb:app_id" meta tag was invalid.

You don't actually have an "fb:app_id" meta tag, but you do have an "fb:admins" meta tag with that value.  Please double check that "153750941361536" really is your Facebook ID.

fokyip

  • Beginner
  • *
  • Posts: 2
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #78 on: July 27, 2011, 22:23:25 pm »
I entered the admin id in the plugin so I don't know why is referring to app_id. The admin id that is used on a module on the front page for facebook friends http://hb.lookmatters.net/ which seems like the ID is correct. Though in my fly page i see a appid when I went to the facebook developers page in there but it's not referring to the admin id and I changed it to the code to website you had for an example demo but its still encountering problems.

<div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#appId=100570196709475&amp;xfbml=1"></script><fb:like send="true" width="450" show_faces="true" font=""></fb:like>

<div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:like send="true" width="450" show_faces="true" font=""></fb:like>

Reggaeshop

  • Jr. Member
  • **
  • Posts: 53
    • Trenchtown Music :: www.reggaeshop.cz
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #79 on: July 28, 2011, 10:32:00 am »
Hello,

I am encountering the same problem as the writer before, However, for me it sometimes does, sometimes does not give an error:
- it most of the time gives the error when I access a product from the small 1-pic slideshow module on the right
- in case there error appears and I refresh the page and click again on like, the error does not appear and the like post is added to my FB profile
- when I access the products by first clicking on the category list on the left and then randomly at a product, no error appears
- when I access the products from the "last product" list below, it shows the error, after refreshing it does not any more when clicking on "Like"

In FB Lint, the error mesage is teh same as for the previous post: It says "You put 1855482553649 in the fb:admins field. It should be in fb:app_id" - but I am quite sure I did not do so.

Only at the first try of the LIKe button after installing, it showed the picture (the right one, the thumbnail), at all later attempts not any more.

- I carefully read this forum thread to the end
- installed using your tutorial at Bigskyphotography
- installed VM Opengraph 1.9
- installed VM Add  Canonical 1.2
- unchecked Cookie check.
- the site: www.reggaeshop.cz

I spent a lot of time on this. The main issue is the error - the pics I see as a secondary thing.

Thanks for your help,

Peter

Reggaeshop

  • Jr. Member
  • **
  • Posts: 53
    • Trenchtown Music :: www.reggaeshop.cz
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #80 on: July 28, 2011, 10:55:17 am »
One more thing - the pic I seem to have solved with your (Kevin's) advise regarding not using the default thumbnail location... let's see if this stays OK ...

kevinwood

  • Jr. Member
  • **
  • Posts: 151
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #81 on: July 28, 2011, 13:58:58 pm »
I entered the admin id in the plugin so I don't know why is referring to app_id. The admin id that is used on a module on the front page for facebook friends http://hb.lookmatters.net/ which seems like the ID is correct. Though in my fly page i see a appid when I went to the facebook developers page in there but it's not referring to the admin id and I changed it to the code to website you had for an example demo but its still encountering problems.


It appears to be working fine now.  I just tried it and had no errors.

kevinwood

  • Jr. Member
  • **
  • Posts: 151
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #82 on: July 28, 2011, 14:09:03 pm »
In FB Lint, the error mesage is teh same as for the previous post: It says "You put 1855482553649 in the fb:admins field. It should be in fb:app_id" - but I am quite sure I did not do so.

It looks like Facebook recently made some changes to how they deal with fb:admins vs fb:app_id.  Let me look into it and I'll get back to you shortly.

kevinwood

  • Jr. Member
  • **
  • Posts: 151
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #83 on: July 28, 2011, 14:31:03 pm »
Trenchtown... please try removing the "appId=165541816838769" from your Facebook like code and see if that fixes the issue.

Reggaeshop

  • Jr. Member
  • **
  • Posts: 53
    • Trenchtown Music :: www.reggaeshop.cz
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #84 on: July 28, 2011, 15:00:02 pm »
Hi Kevin, thanks for replying so quickly.

From the code  what exactly I have to delate? /all.js#appId=165541816838769&amp;xfbml=1">   

All between # and &amp, or a bit more?

Thanks,

Peter

kevinwood

  • Jr. Member
  • **
  • Posts: 151
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #85 on: July 28, 2011, 15:20:26 pm »
Just between the # and & should do it.

Reggaeshop

  • Jr. Member
  • **
  • Posts: 53
    • Trenchtown Music :: www.reggaeshop.cz
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #86 on: July 28, 2011, 15:47:28 pm »
:( Still the same. I cleared cache and cookies, tried it again (select a pic form the 1-pic slide show, click "like"), and the error appeared again.

However, when doing this for a second and third time, it went OK.

When I cleared Cache/cookies again, and repeated the action (select a pic form the 1-pic slide show, click "like"), the error appeared again....

Michele Rocco

  • Beginner
  • *
  • Posts: 7
    • Creazioni WEB Michele Rocco
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #87 on: July 31, 2011, 01:57:04 am »
Hi, I need help if you can.

I have installed the plugin and put the fb code in flypage, the Send and Like button works right but they always take the last additional pic of my products.
I looked the og:img tag and it have the right pic url inside so I don't understand why FB is taking the last additional pic of my products and not the right first image.

What could be?

Thanks, michele
Creazioni WEB Michele Rocco - Joomla & Virtuemart Design, Installation & Coding
www.michelerocco.com
www.creazioniwebmr.com

kevinwood

  • Jr. Member
  • **
  • Posts: 151
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #88 on: August 05, 2011, 14:19:02 pm »
Hi, I need help if you can.

I have installed the plugin and put the fb code in flypage, the Send and Like button works right but they always take the last additional pic of my products.
I looked the og:img tag and it have the right pic url inside so I don't understand why FB is taking the last additional pic of my products and not the right first image.

What could be?

Thanks, michele

Can you post a link to one of your pages?

kevinwood

  • Jr. Member
  • **
  • Posts: 151
Re: Tutorial: How to get Facebook Like working on your Virtuemart site
« Reply #89 on: August 05, 2011, 14:25:08 pm »
:( Still the same. I cleared cache and cookies, tried it again (select a pic form the 1-pic slide show, click "like"), and the error appeared again.

However, when doing this for a second and third time, it went OK.

When I cleared Cache/cookies again, and repeated the action (select a pic form the 1-pic slide show, click "like"), the error appeared again....

Trenchtown, can you check to see if "1855482553649" is your Facebook user ID?