Author Topic: Upgrade patch from 1.1.7a to 1.1.8 Error: Failed to parse the XML Update File  (Read 16008 times)

da_vinci

  • Beginner
  • *
  • Posts: 5
Hello, after checking updates system is showing error, I have try to upload patch to cache folder but error still exist, have you any ideas what to do?

roeroelectric

  • Beginner
  • *
  • Posts: 24
    • Ro&Ro Electric Italian Lighting
  • Skype Name: roero-electric
I have same problems.

It is not possible the upgrade from 1.1.7 to 1.1.8.

After the upload of the patch my version of Virtuemart is always the 1.1.7
Marcello Role

FnF

  • Beginner
  • *
  • Posts: 16
What is the upgrade process you are using?

You should download patch first, then...
Log into your VM install
Go to Admin on the menu, scroll down to "check for updates"

As of last night the download patch directly from here wasnt working, so use upload patch. On "check for updates" page, click "upload patch" tab.

Find the patch you downloaded prior, click upload and preview, and follow the on screen instructions, which is just a few clicks.

avkeele

  • Jr. Member
  • **
  • Posts: 50
I experienced the same problem. Now I get "Error: Failed to parse the XML Update File." if I try to access Virtuemart's update page, so I cannot upload and install the patch package I since downloaded directly from Virtumart.

Now I'm stuck.

bhemusic

  • Beginner
  • *
  • Posts: 8
Same problem here.

Does anybody know if 1.1.8 is going to fix the lightbox mootools collision?

zanardi

  • Contributing Developer
  • Full Member
  • *
  • Posts: 878
    • GiBiLogic
I just tested the 1.1.7 to 1.1.8 update patch without issue. As FnF mentioned, the correct procedure is to download the patch from VirtueMart site, then go to VirtueMart administration, then click on "Upload a patch", and everything should work.

@bhemusic: VM 1.1.8 introduces MooTools 1.2 compatibility; i don't know what specific lightbox collision you refer to.
--
Francesco (zanardi)
http://extensions.gibilogic.com
@gibilogic on Twitter

EdgeCrafter

  • Beginner
  • *
  • Posts: 21
    • EdgeCrafter
  • VirtueMart Version: VM 3.2.1
I just tested the 1.1.7 to 1.1.8 update patch without issue. As FnF mentioned, the correct procedure is to download the patch from VirtueMart site, then go to VirtueMart administration, then click on "Upload a patch", and everything should work.

I can confirm manual update procedure for 1.1.7 -> 1.1.8 works perfectly.

bhemusic

  • Beginner
  • *
  • Posts: 8
I just tested the 1.1.7 to 1.1.8 update patch without issue. As FnF mentioned, the correct procedure is to download the patch from VirtueMart site, then go to VirtueMart administration, then click on "Upload a patch", and everything should work.

I can confirm manual update procedure for 1.1.7 -> 1.1.8 works perfectly.

Did you upgrade from 1.1.7a or 1.1.7?

I have 1.1.7a and it is still not working...

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Apparently, the dev team forget to prepare an upgrade patch from version 1.1.7a to 1.1.8.
One possible workaround is to manually change the version.php file in the existing 1.1.7a site to return 1.1.7 instead of 1.1.7a. I have not tried this and not sure whether this will work.
Meanwhile, the dev team should provide a solution.


Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

da_vinci

  • Beginner
  • *
  • Posts: 5
Hello, after checking updates system is showing error, I have try to upload patch to cache folder but error still exist, have you any ideas what to do?
Next day i have login to system and try check updates and everything start working again :-), so problem is fixed.

bhemusic

  • Beginner
  • *
  • Posts: 8
I just tried to upgrade again and it is still NOT working for me.

websitefreedom

  • Beginner
  • *
  • Posts: 4
I have 1.1.7 and also get the error message after downloading 1.1.18. Any ideas? Is waiting a day the workaround?

Kummer Daniela

  • Beginner
  • *
  • Posts: 12
I'm having the very same problem: I have VirtueMart1.1.7a and cannot update using the 1.1.7 to 1.1.8 patch in the update/patch section in VirtueMarts administration.

This is really bad as the shop I'm working on is supposed to go life on 6th april and I'm having big problems with the PayPal API that I hope can be resolved with the new version...

And I don't exactly have the time to completely deinstall, reinstall and configure the whole shop  :'(
To see a World in a Grain of Sand and Heaven in a Wild Flower, to hold Infinity in the palm of your hand and Eternity in an hour
- is inspiration.

(Fragments from "Auguries of Innocence" by William Blake)

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27767
  • Always on vacation
    • Jenkin Hill Internet
Download the patch and use ftp to overwrite the existing files.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.4.10335 on Joomla 3.9.19 PHP 7.3.18

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Just found most (if not all) of the download location reported by the auto update function are incorrect. So the most reliable way to upgrade is to use ftp method.
1. download patch from http://virtuemart.net/downloads
2. unzip the package in your local computer
3. Use ftp to upload the directories administrator and components to your Joomla root.

For 1.1.7a, you can use the same patch as 1.1.7.
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.