Author Topic: v1.1.6 back end unstable REALLY need help!  (Read 5883 times)

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10406
  • VirtueMart Version: 3+
Re: v1.1.6 back end unstable REALLY need help!
« Reply #15 on: February 13, 2011, 22:00:17 pm »
have you replaced the files?
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

DebbyP

  • Beginner
  • *
  • Posts: 22
Re: v1.1.6 back end unstable REALLY need help!
« Reply #16 on: February 15, 2011, 23:45:04 pm »
I have but no solution to the back-end problem.  I just don't know where to go next.  The Admin file that you provided I was unable to open so I went back to the update patches. It didn't work.

Looking at the error console after clicking on List Products, I have this error:
Error: Fat is not defined
Source File: http://xxxxxx.com/administrator/index.php?pshop_mode=admin&page=product.product_list&option=com_virtuemart
Line: 691

When I click on it to find out the problem this is what it points to:
<td><a title="Clone Product" onmouseout="MM_swapImgRestore();" onmouseover="MM_swapImage('copy_3','','http://xxxxxx.com/components/com_virtuemart/shop_image/ps_image/copy_f2.gif',1);" href="http://xxxxxx.com/administrator/index.php?page=product.product_form&amp;clone_product=1&amp;limitstart=0&amp;keyword=&amp;product_id=38&amp;option=com_virtuemart"><img src="data:image/gif;base64,R0lGODlhEwATAPcAAP///+fn59bW1sbGxt7e3s7Ozr29vbW1te/v7/////f3962trQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAACH5BAkAAAAALAAAAAATABMAAAjLAAEIFIggQIEBAwwgGMgQgAKDCAUQKGiAQEOBBwtMRKCgIIIBFi8eCMCxI4KSIAMQkLgQwICTMAOoDGBgQAEBAioKfCmTAIGDNgmQPAlyJ8yPGhce/RjyZcEATpdyvIkxgIKrUWVqVUAVgEYACAjw3NhRAQABBQgKcPiR40mtCw2aVSDALFSrZE92fClQqEOJBGdyBLBSrUyqBecWdFjALACoCBuDhTswwFqBJOm6dezQ8sGLKhWvRDhAQICLZ3ECNW0VNcGDpjkPDAgAOw==" name="copy_3" border="0" alt="Clone Product"/></a></td>

What's up with all the A's, would you know?

It's weird but although the Buttons don't work but if you don't check an item and try to add attribute, publish, un-publish etc. the correct warning comes up asking you to check a product first, if you check an item and then click on one of the buttons it doesn't do anything.

Error Message:
Error: MM_swapImage is not defined
Source File: http://xxxxxx.com/administrator/index.php?pshop_mode=admin&page=product.product_list&option=com_virtuemart
Line: 1

Line 1 says:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

I do appreciate the help you are trying to provide.  Let me know if there is anymore information that you need if I'm not being clear.  Right now I feel like I'm running in circles and not helping you at all.
DebbyP

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10406
  • VirtueMart Version: 3+
Re: v1.1.6 back end unstable REALLY need help!
« Reply #17 on: February 16, 2011, 02:01:38 am »
what happens when you switch the view in vmart admin?


J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: v1.1.6 back end unstable REALLY need help!
« Reply #18 on: February 16, 2011, 06:28:13 am »
Debby,
Can you use View Page Source, cut and paste the html text and posted here as an attachment? Look like the file has some strange tags.
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

DebbyP

  • Beginner
  • *
  • Posts: 22
Re: v1.1.6 back end unstable REALLY need help!
« Reply #19 on: February 16, 2011, 08:32:30 am »
what happens when you switch the view in vmart admin?

If I switch to Extended View, and pull up a product then there are no buttons to save, apply or cancel.



DebbyP

  • Beginner
  • *
  • Posts: 22
Re: v1.1.6 back end unstable REALLY need help!
« Reply #20 on: February 16, 2011, 08:34:07 am »
Debby,
Can you use View Page Source, cut and paste the html text and posted here as an attachment? Look like the file has some strange tags.

Which page would you like me to post?

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: v1.1.6 back end unstable REALLY need help!
« Reply #21 on: February 16, 2011, 08:41:20 am »
The page you mentioned above.
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

DebbyP

  • Beginner
  • *
  • Posts: 22
Re: v1.1.6 back end unstable REALLY need help!
« Reply #22 on: February 16, 2011, 17:15:20 pm »
Attached source file for product list page.  I've changed the domain name to xxxxxx.
I appreciate you taking a look at this.  Hope you can see something, it's evident that I can't see it.

[attachment cleanup by admin]

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: v1.1.6 back end unstable REALLY need help!
« Reply #23 on: February 16, 2011, 17:58:01 pm »
Hmm... there are many tags got translated. Do you have a php function that parses the html before sending out to the browser?
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

DebbyP

  • Beginner
  • *
  • Posts: 22
Re: v1.1.6 back end unstable REALLY need help!
« Reply #24 on: February 16, 2011, 20:44:09 pm »
I'm sorry, I don't know what you are talking about.  If you can explain how to do that I would be happy to try.

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10406
  • VirtueMart Version: 3+
Re: v1.1.6 back end unstable REALLY need help!
« Reply #25 on: February 16, 2011, 21:12:34 pm »
have you tried different browsers>
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

DebbyP

  • Beginner
  • *
  • Posts: 22
Re: v1.1.6 back end unstable REALLY need help!
« Reply #26 on: February 16, 2011, 21:28:19 pm »
Well thank you to both BanquetTables.pro and Joseph Kwan for your help with this issue, I have found the culprit for the problem with the back end on the two sites that were not working properly and what was really different between those two and the one that was working just fine.

In looking at the server (domain) setups I had enabled a "beta" Page Speed Optimization module http://code.google.com/speed/page-speed/ for the website on the two that are having problems and hadn't on the one that wasn't having a problem.  So as an experiment I turned it off on the one and now the backend seems to be working correctly.

Once I turned the Page Speed Optimization OFF they are working just fine other than they are throwing warnings regarding dropped Declarations in the xtheme-gray.css file. At least they aren't full out errors.

Again thank you so much for your input and help, it kept me looking deeper.

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: v1.1.6 back end unstable REALLY need help!
« Reply #27 on: February 16, 2011, 21:46:00 pm »
Debby,
Thanks for posting back the findings. As I have advised in the PM, the html seemed to be parsed before sending out to the browser. It's good you finally located the parser.

The actual problem seems to be that the optimization engine translated many of the tags trying to put image and javascript files inline using the data: url scheme. Unfortunately this new url scheme is not recognized by the browser and caused lots of javascript error.

Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

DebbyP

  • Beginner
  • *
  • Posts: 22
Re: v1.1.6 back end unstable REALLY need help!
« Reply #28 on: February 17, 2011, 08:30:27 am »
My problem, with the back end being unstable, had to do with an option on my server to turn on a program called "Page Speed Optimization" for the domain.  Once I turned it off or unchecked it my program ran just fine.  This was not something in Joomla or VirtueMart but on my host.

As Joseph Kwan explains it, "The actual problem seems to be that the optimization engine translated many of the tags trying to put image and javascript files inline using the data: url scheme. Unfortunately this new url scheme is not recognized by the browser and caused lots of javascript error."

So I would look either to your host to see if there is an optimization program running on the domain or have you installed some kind of page optimization program or module.

Hope that helps.
Debby