Author Topic: [FIXED] Customer Reviews breaks on 150 character and has no line break  (Read 3986 times)

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Customer Reviews breaks on 150 characters

To fix the issue.
Look for the following line of code in reviews.tpl.php file (file located in theme folder)
Code: [Select]
<blockquote><div><?php echo wordwrap($review['comment'], 150"<br/>\n"true ); ?></div></blockquote>
Replace it with
Code: [Select]
<blockquote><div><?php echo wordwrap($review['comment'] ); ?></div></blockquote>

However now the customer review has no line break or styling (bold, italic and etc) this should be added, at least line break.

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: Customer Reviews breaks on 150 character and has no line break
« Reply #1 on: March 03, 2011, 21:44:54 pm »
I see this has been fixed in SVN however there is a strange issue, when I use administrator user review has line breaks when I use registered user review doesn't have line breaks instead shows rnrn.

Example.
This is first line.rnrnThis is second line.

zanardi

  • Contributing Developer
  • Full Member
  • *
  • Posts: 878
    • GiBiLogic
Re: Customer Reviews breaks on 150 character and has no line break
« Reply #2 on: March 04, 2011, 00:22:36 am »
Surely there is an escape function missing. I will have a look at this if i have time before packaging 1.1.8 BETA (i hope to have it ready by the end of next week).
--
Francesco (zanardi)
http://extensions.gibilogic.com
@gibilogic on Twitter