Author Topic: Google indicization, all categories some products.  (Read 1179 times)

inTroubles

  • Beginner
  • *
  • Posts: 37
Google indicization, all categories some products.
« on: January 18, 2011, 09:42:58 am »
Hi,
why does google has indicized all my shop categories (up to 300) and just some products? products are like 5000 but i got only 20-30 of them indicized on google.
Each product is very different from another one, different keywords, images, description, titles and so on.
I am actually using this hack because would be impossible for me to edit one by one metatags: http://forum.virtuemart.net/index.php?topic=65697 sef is on plus xmap and sent the sitemap to google which recognize 5533 links with no errors.  
I do know there can be alot of reasons but what can i check to optimize the website? the site is not so old it's online from about 1 month.

Thank you.

stinga

  • Contributing Developer
  • Full Member
  • *
  • Posts: 872
    • Squangle ltd
Re: Google indicization, all categories some products.
« Reply #1 on: January 18, 2011, 11:44:01 am »
G'day,

You have answered your own question, it is only 1 month old.
Speed might also be an issue, slow sites take longer to index (I think).
Have a look in google webmaster and see what it is downloading.
If the site is slow I bet google gets bored.
Stinga.
614869 products in 747 categories with 15749 products in 1 category.
                                             Document Complete   Fully Loaded
                Load Time First Byte Start Render   Time      Requests      Time      Requests
First View     2.470s     0.635s     1.276s          2.470s       31            2.470s      31
Repeat View  1.064s     0.561s     1.100s          1.064s       4             1.221s       4

inTroubles

  • Beginner
  • *
  • Posts: 37
Re: Google indicization, all categories some products.
« Reply #2 on: January 18, 2011, 14:38:28 pm »
Hello there,
thank you for the answer, yeah indeed it's only 1 month older my question popped out because i seen that some products are indexed others not, for this reason i've think that maybe i have something misconfigured.
About the server performance, the link to the sitemap is ofc a bit slow because xmap generates about 5k links, however the rest of website runs pretty smooth for users, it takes few seconds to load pages, i didnt noticed any problem with it.
Here's google webmaster tools speed report, dunno if this is what you mean:
Time to load a page in milliseconds: High: 2.205 Medium: 1.323 Low: 409
Regards and thanks