Author Topic: Advanced Search according to Parameters can't find exact float values  (Read 4197 times)

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Advanced Search according to Parameters can't find exact float values

The ‘Advanced Search according to Parameters’ is not able to find the correct product(s) if the searched parameter is a float value, example.
The following products have the following product_type_values:
Prod-A  10.4, Prod-B  10.5, Prod-C  12.3
Searching for 10.4 with the comparison operator '=' doesn't return any product.

zanardi

  • Contributing Developer
  • Full Member
  • *
  • Posts: 878
    • GiBiLogic
--
Francesco (zanardi)
http://extensions.gibilogic.com
@gibilogic on Twitter


zanardi

  • Contributing Developer
  • Full Member
  • *
  • Posts: 878
    • GiBiLogic
Re: Advanced Search according to Parameters can't find exact float values
« Reply #3 on: November 08, 2010, 10:14:16 am »
Can you please tell me the steps to reproduce the issue on your test site? Which product? Which parameter?
--
Francesco (zanardi)
http://extensions.gibilogic.com
@gibilogic on Twitter

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: Advanced Search according to Parameters can't find exact float values
« Reply #4 on: November 08, 2010, 18:53:51 pm »
From the left menu click on 'Advanced Search according to Parameters' next select 'Product Info' leave default setting for all parameter values except 'Camera Effective Pixels' set it to '=' select 8.1 and search, no result is found but there is a product with 8.1 value, set '<=' select 9.1 and search only one result is found but there should be two products, next set it to '>' search two product are found but only one should be.