Author Topic: Fatal Error: Call to undefined method ps_cartt::countaddons() shop.cart.tpl.php  (Read 12220 times)

johnathanamber

  • Beginner
  • *
  • Posts: 19
Hey everyone!

I've updated from 1.1.14 to 1.1.15 and updated to the latest FedEx (1.1.15) update.

I get the following error when I try to add to my cart:
Quote
Fatal error: Call to undefined method ps_cart::countaddons() in /home/content/t/s/g/tsgcomputers/html/sites/aviatorsauction/components/com_virtuemart/themes/default/templates/pages/shop.cart.tpl.php on line 31

So I commented out the following in the shop.cart.tpl.php:
Quote
//    $addons = ps_cart::countAddOns($product_id);
//    $maxaddons = ps_cart::countAllowedAddOns($product_id);

When I did this I get the following error:
Quote
Fatal error: Call to undefined method ps_cart::countaddons() in /home/content/t/s/g/tsgcomputers/html/sites/aviatorsauction/administrator/components/com_virtuemart/html/checkout.index.php on line 37

I've checked settings and such and can't seem to find a config issue on our part...

I've reverted that changes I've made in 'shop.cart.tpl.php'.

Any help would be greatly appreciated.

Thank you,
Johnathan

johnathanamber

  • Beginner
  • *
  • Posts: 19
Does anyone have any suggestions on how to resolve this?

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Is this the VM1.1.5 FedEx module, or perhaps my FedExv2 module?
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

johnathanamber

  • Beginner
  • *
  • Posts: 19
Uh, honestly I do not remember... can I tell via one of the files installed?

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
If it were my FedExv2 module, you'd definitely know it, haha.

The error points to missing functions in ps_product, which leads me to believe that either you've installed some modifications that were overwritten during the upgrade, or the modifications overwrote some of the new VM1.1.5 files.

Either way, your ps_product class file is missing some code.  I'm not near my source to look at the VM115 code, so I can't tell you which it is.
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

johnathanamber

  • Beginner
  • *
  • Posts: 19
@lowmips,

I believe that I downloaded the official package, not the one you provide.

The version is:
FedExv2.2010.08.10

Copyright Reggie Campbell

License: http://www.gnu.org/copyleft/gpl.html GNU/GPL

With that being said, does anyone have and ideas?

Thank you,
Johnathan

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
That is my module.  Has my name all over it :)

It looks like the issue is your version of ps_cart is not the version provided with my module.  You'll need to re-install the ps_cart file from the archive.

/administrator/components/com_virtuemart/classes/ps_cart.php

Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

johnathanamber

  • Beginner
  • *
  • Posts: 19
Reggie,

Thank you for helping out with this.

Now I get the following error:
"Error: FedEx Return Error 5010 : No sender account number."

Where would I place this information?

Thank you,
Johnathan

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Jonathan,
You should enter your FedEx Web Services credentials in the shipping module configuration.

Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

johnathanamber

  • Beginner
  • *
  • Posts: 19
Hello Reggie,

Thank you for your help thus far...

After reuploading the ps_cart file... we can no longer add file to the shopping cart.

Mind you that we've upadted from VM 1.1.14 > 1.1.15 AND USED YOUR 1.1.15 FedEx patch... Anything you can think of to help?

Thank you,
Johnathan

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
At this point, I would advise you to completely re-install vm115-FedExv2.2010.08.10.

Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

johnathanamber

  • Beginner
  • *
  • Posts: 19
Reggie,

OK we did reinstall both VM and the FedEx module.

However we are not getting any rates...

I want to be sure that I have this info right:
Production
Web Access Key = Authentication Key (provided from the Confirmation WebPage, not in email)
Web Access Password = Production Password (provided from the confirmation email)
Account Number = FedEx Account Number (provided from the confirmation email)
Meter Number = Production Meter Number (provided from the confirmation email)

I have entered these into the module and we are still not getting any rates.

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Yes, those are correct.  Have you placed the module, and VirtueMart, in debug mode to obtain further information about the rates issue?

Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

johnathanamber

  • Beginner
  • *
  • Posts: 19
I found the issue...

problem was the site owner... the one who added the products, didn't add a weight to the items... so the shipping wasn't calculated since it didn't have that variable...

Once I added a weight... viola!

Thank you Reggie and everything for your help!

God bless,
Johnathan