Author Topic: What am I missing: no ship to, no Bill to, No order  (Read 1283 times)

kessels1234

  • Jr. Member
  • **
  • Posts: 208
What am I missing: no ship to, no Bill to, No order
« on: June 25, 2010, 21:42:40 pm »
Hi,

I don't know if I'm missing a point but I did a fresh install of virtuemart 1.1.4 with sampledata (and without) on joomla 1.5.15 (several). When I make an order I can complete all of the steps but on the order confirmation (to customer and to admin), accountmaintenance, user info (in backend) there are no ship to and bill to details.

In the user info (backend) and accountmaintanance I can see the order without previously mentioned details. When I go (in the backend) to orders then it doesn't show any order???????

I have some (test) sites with virteumart 1.1.3 and this problem is not an issue?

Can anyone tell me what I'm missing?

Thanks in advance
Danny

kessels1234

  • Jr. Member
  • **
  • Posts: 208
Re: What am I missing: no ship to, no Bill to, No order
« Reply #1 on: June 25, 2010, 23:21:45 pm »
Did some testing and turned on debugging. In the last final step when you complete the order I get a 500 server error with the following message:

500 - JDatabaseMySQL::query: 1267 - Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation 'find_in_set' SQL=SELECT f.* FROM `jos_vm_userfield` f WHERE f.published=1 AND f.type != 'delimiter' AND FIND_IN_SET( f.name, 'username,password,password2,agreed') = 0 ORDER BY f.ordering

Maybe this gives someone a clue

Thanks in advance
Danny

kessels1234

  • Jr. Member
  • **
  • Posts: 208
Re: What am I missing: no ship to, no Bill to, No order
« Reply #2 on: June 25, 2010, 23:49:33 pm »
Further investigation:

It turns out that (almost) all of my joomla tables are UTF8_general_ci and when I install virtuemart all the vm tables are Latin1_swedish_ci

If this causes my problem the I think it's a bug in virtuemart

Any comments on this are welcome
Danny

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27502
  • Always on vacation
    • Jenkin Hill Internet
Re: What am I missing: no ship to, no Bill to, No order
« Reply #3 on: June 26, 2010, 22:28:22 pm »
The VirtueMart install SQL files have no charset defined so will use the default server MySQL charset - for me that is UTF-8 Unicode (utf8)

Check to see if your default is Latin/Swedish
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.6.1.10121 on Joomla 3.9.11 PHP 7.0.33
Testing 3.6.1.10129 on Joomla 3.9.11