Author Topic: Error: Failure in Processing the Payment (ps_paypal_api)  (Read 26692 times)

zanardi

  • Contributing Developer
  • Full Member
  • *
  • Posts: 878
    • GiBiLogic
Re: Error: Failure in Processing the Payment (ps_paypal_api)
« Reply #15 on: March 19, 2011, 12:48:13 pm »
It looks like it could be a PayPal account type issue. I.E., you have to have "business" account to use Website Payment Pro, which is implemented by new PayPal API.
--
Francesco (zanardi)
http://extensions.gibilogic.com
@gibilogic on Twitter

Tiger452

  • Beginner
  • *
  • Posts: 1
Re: Error: Failure in Processing the Payment (ps_paypal_api)
« Reply #16 on: May 08, 2011, 15:47:30 pm »
Does anyone know a way to disable the credit card option on the shop and just have Paypal payment option? This could be another solution, instead of having to get the website pro payment.
Thank

rajeev108

  • Beginner
  • *
  • Posts: 5
Re: Error: Failure in Processing the Payment (ps_paypal_api)
« Reply #17 on: May 31, 2011, 21:21:03 pm »
I am using Your VirtueMart version: VirtueMart 1.1.8 stable [Little brother] 19/03/2011 12:11 GMT.

I am getting the following error on checkout which I have edited for sensitive info:

Error: Error - Paypal did not complete the transaction - FAILURE - SHORTMESSAGE =Transaction refused because of an invalid argument. See additional error messages for details. -
ERRORCODE =10413 -
LONGMESSAGE =The totals of the cart item amounts do not match order amounts. -
&PAYMENTACTION=Sale&IPADDRESS=127.0.0.1&CREDITCARDTYPE=Visa&ACCT=XXXX&EXPDATE=042012&EMAIL=xxx%40yahoo.co.uk&FIRSTNAME=Test&LASTNAME=User&CVV2=000&STREET=test+address1&CITY=Test+city&STATE=EN&COUNTRYCODE=GB&ZIP=XX5+3XX&SHIPPINGAMT=6.39&CURRENCYCODE=GBP&TAXAMT=0.2&DESC=&INVNUM=66_863368f0018ef7cc8&BUTTONSOURCE=Virtuemart_Cart_DP&L_AMT0=1&L_QTY0=1&L_NAME0=Hammer&ITEMAMT=1&AMT=8.87&SHIPTONAME=Test+User&SHIPTOSTREET=test+address1&SHIPTOSTREET2=test+address+2&SHIPTOCITY=Test+city&SHIPTOSTATE=EN&SHIPTOZIP=SW15+3QJ&SHIPTOCOUNTRYCODE=GB
Error: Error - Paypal did not complete the transaction. Please try again in a little while.
Error: Failure in Processing the Payment (ps_paypal_api)

The PayPal forum tells me that AMT should equal ITEMAMT+TAXAMT+SHIPPINGAMT+HANDLINGAMT

Looking at my transaction details it seems that TAXAMT field just has VAT for the product item but not the postage. However, at the time of checkout it correctly shows the VAT for both product and shipping. Is there a bug in ps_paypal_api?

rpolanco

  • Beginner
  • *
  • Posts: 1
Re: Error: Failure in Processing the Payment (ps_paypal_api)
« Reply #18 on: August 23, 2011, 23:14:16 pm »
the original posting for where the problem resolution is found is as follows: http://forum.virtuemart.net/index.php?topic=87202.0

I have resolved the problem by modifying ps_paypal_api.php line 1748 to be:

$ship_total = isset($d['shipping_total']) ? round($d['shipping_total'] + $d['shipping_tax'] ,2) : 0;

It seems that elsewhere the SHIPPINGAMT field of PayPal API is set with value including shipping VAT but here it is not. For example, if we look at line 1653 it is clearly adding shipping VAT:

$shippingamt = round($order_totals['order_shipping']+$order_totals['order_shipping_tax'],2);

It seems to be a bug in VirtueMart and I am new to the product so those who are familiar with the product can report it as a bug and get it rectified in future additions.

useris

  • Jr. Member
  • **
  • Posts: 224
Re: Error: Failure in Processing the Payment (ps_paypal_api)
« Reply #19 on: December 17, 2011, 15:40:40 pm »

It did not solved the problem for me.
the original posting for where the problem resolution is found is as follows: http://forum.virtuemart.net/index.php?topic=87202.0

I have resolved the problem by modifying ps_paypal_api.php line 1748 to be:

$ship_total = isset($d['shipping_total']) ? round($d['shipping_total'] + $d['shipping_tax'] ,2) : 0;

It seems that elsewhere the SHIPPINGAMT field of PayPal API is set with value including shipping VAT but here it is not. For example, if we look at line 1653 it is clearly adding shipping VAT:

$shippingamt = round($order_totals['order_shipping']+$order_totals['order_shipping_tax'],2);

It seems to be a bug in VirtueMart and I am new to the product so those who are familiar with the product can report it as a bug and get it rectified in future additions.

nasowos

  • Beginner
  • *
  • Posts: 3
Re: Error: Failure in Processing the Payment (ps_paypal_api)
« Reply #20 on: March 02, 2012, 16:53:17 pm »
Hey guys,

I have also had this problem from the thread starter until today:

I just installed the Paypal pro module. I entered my API info and when I check out I get..

Error: Error - Paypal did not complete the transaction. Please try again in a little while.
Error: Failure in Processing the Payment (ps_paypal_api)

I tryed a lot. Then I made something undone: The hack to avoid displaying the unwanted Credit Card payment method: http://www.aglobalweb.com/aglobalweb/blog/2-virtuemart/48-virtuemart-paypal-api-bugs-and-solutions.html

So I replaced the "fixed" ps_checkout.php and ps_payment_method.php with the original, backuped ones and the problem did never occur again! So this "fix" was the problem! (At least in my case.)

So this problem was solved, while another appeared again: the unwanted credit card payment method. I fixed it rather simple myself by commenting out the following line in the list_payment_methods.tpl.php, which is responsible for diplaying the (paypal related) credit card payment method:

Code: [Select]
// $ps_payment_method->list_paypalrelated($payment_method_id,  false);
Simply paste the "//" in front of this code line and you will be rid of the credit card payment method and all works fine (at least in my case).

Please let me know if this worked for you guys (as I am surely not the only one who is fu**ing around with all these annoying virtuemart bugs)..

Best wishes, colleagues!

vandusendesign

  • Beginner
  • *
  • Posts: 2
Re: Error: Failure in Processing the Payment (ps_paypal_api)
« Reply #21 on: March 09, 2012, 20:55:45 pm »
I am getting the general "Error: Failure in Processing the Payment (ps_paypal_api)".  Only on the CC form method.  I have been back and forth with PayPal and through every forum I can find online, and am still having this issue. 

Can anyone give me some direction with this issue?

https://www.thegreatunbaked.com/store.html?page=shop.browse&category_id=1
LIVE MODE

VM 1.1.8
Joomla 1.5.25
PayPal (NEW API)