Author Topic: Discount does not show red line. Help me !  (Read 6767 times)

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: Discount does not show red line. Help me !
« Reply #15 on: April 06, 2010, 07:19:28 am »
That wasn't me suggesting that, but austim is right. If you add the css to your Joomla template css, it should work.  To me, it just sounds like you still have a caching and or GZIP issue. If you are making direct changes to your Joomla template css, and you see not changes, then there is no other cause.

agaze10

  • Beginner
  • *
  • Posts: 7
Re: Discount does not show red line. Help me !
« Reply #16 on: April 06, 2010, 13:40:37 pm »
It has beaten me!! I went to Joomla/templates/Rt-solarsentinel/CSS/template-CSS and tried the code under every heading and couldn't resolve the issue.  Really appreciate your help Forrest and Austim. Paid the bucks from Rocketthemes and can't get a peep out of them. Great effort by you blokes to at least try to help out.  Thanks.

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: Discount does not show red line. Help me !
« Reply #17 on: April 06, 2010, 19:47:10 pm »
You can PM me your ftp and J! admin login.

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: Discount does not show red line. Help me !
« Reply #18 on: April 07, 2010, 03:27:40 am »
Ok, fixed.

Since you are using Yagendoo, the element span on those pages is actually:
yagendoo_productOldPrice

You will see that is what I used in your css, and it worked immediately. You can always check your elements using an element inspector!

Download Google Chrome, and right click any element and select "Inspect Element". You will see in the case of your Original price, that the class applied to that element is: yagendoo_productOldPrice.

Essentially, get used to checking your elements using an element inspector. It will save you a  lot of time and energy.

Vinn0

  • Beginner
  • *
  • Posts: 3
Re: Discount does not show red line. Help me !
« Reply #19 on: April 26, 2010, 12:26:45 pm »
I'm having the same problem but I cannot for the life of me figure out how to fix it.

I'm also using yagendoo.

My "featured product" module displays the price correctly. When I use firebug to examine it, it has the span "yagendoo_productOldPrice"

However, both my browse page and my product pages have the span "product-Old-Price". When I change this in firebug, the price changes to red with a line-through, which is great but obviously not very effective in the long term.

I just can't figure out where to do this in my files. It would be great if someone could help me on this.

http://www.kahuvet.co.nz/index.php?option=com_virtuemart&Itemid=57

Thanks,

Vinn0

Vinn0

  • Beginner
  • *
  • Posts: 3
Re: Discount does not show red line. Help me !
« Reply #20 on: April 27, 2010, 11:58:22 am »
Fixed it.

Since I was also using yagendoo, I presumed that I would need to use yagendoo_productOldPrice in the css. After that didn't work, I tried it with product-Old-Price again and this time it worked. Not sure why...